Download

iOS blueprint only PC build failed

Hi,
I am using Win10 64bit, UE4.19.2 and
[SIZE=13px][SIZE=13px]I’ve been working with ARKit for a week now. [/SIZE][/SIZE]
I had a working ARKit project installed on iPhone 8 using UE4.19.2.Last week I installed the new UE4.20Preview to check out the new ARKIT 2.0 (new plane detection, better tracking, etc.). The certificate and the mobile provision were okay (GREEN) I launched the app and it asked for Remote Compiling. So I decided to go back to my old 4.19 project and continue working there, because I thought that 4.20 is Preview version and it’s not working well, but the Remote [SIZE=13px][SIZE=13px]Compiling [/SIZE][/SIZE]error showed even in my old project where I was working all week with no problems. I can’t get rid of the “Remote compiling requires a server name.” error.

Here are the things I’ve tried using UE4.19.2:

1.I uninstalled all UnrealEngine versions that I had and installed only 4.19.2, again new certificates and provisions, but Remote Compiling still here.

  1. My project is BLUEPRINT ONLY using the built-in HandheldAR template no 3rd party plugins.(If you have 3rd party plugins they require Xcode compilation)

  2. I added a script in DefaultEngine.ini

[/Script/IOSRuntimeSettings.IOSRuntimeSettings]

bUseRSync=False

Thi[SIZE=13px][SIZE=13px]s is suppose to disable remote building. It’s enabled by default. It did not work. [/SIZE][/SIZE]

  1. Tried to delete the following project folders Saved, Intermediate, Build and Binaries.

  2. Tried to delete the two rows in DefaultEngine.ini saw that in another thread, but all it does is resets BundleName and BundleDisplayName under Project Settings - Platforms - IOS - Bundle Information

BundleName=ARFactory
BundleDisplayName=ARFactory

  1. In another thread was mentioned that a clean Blueprint only iOS App will work on PC but the ARKit requires a Xcode Compilation on its own, so I made a new project without ARKIT to see if the plugin requires some Xcode compilation and is the cause of the error. Same result it wants the server again. So the problem is not in ARKit plugin because I was working with it a day ago and there is no difference if the project is with or without the plugin.

Are you running a version of the engine that you compiled from source? if so then you have to do a remote compile, there is no other option. Only the binary downloaded from Epic allows you to launch the game on an iOS device without doing a remote compile. I would recommend installing the 4.20 binary from the epic games launcher and then trying to launch one of the start up demo projects on a device

I am using 4.19.2 installed from Epic Launcher not compiled from source. I am trying to avoid everything that has source code to make sure that it doesn’t need additional compilation and ask for remote build.

Hi MOSBozhidar,

I read your reply to me over onthis thread. If you are working straight from the Launcher installation, what I’d recommend doing is:

  1. Package and test a completely new template project just to confirm that you can launch / package an iOS blueprint project from the engine without the remote build error occurring.
  2. Migrate your level / assets across to a new project and try to launch / package each time. Don’t do too much at once.

I have had some very weird stuff happen, especially after a crash - project settings have been dumped or corrupted etc. I think it is a very smart workflow to build in modular chunks (thanks to whoever on here started me doing that). I was able to migrate my main game across to another project as a single level and then just call it via streaming from the persistent level in the new project. This killed off any weird project settings issues I had in that case.

You’ve probably already tried something similar. Sorry I couldn’t offer anything more directly useful. I’m still veeeeery new to UE4. :slight_smile:

Good luck!

Hi LoneScrapBot
Unfortunately I tried a completely new blank project with no changes in it. I made my certificates and mobileprovisions but it still wants me to do a remote build. The project is not the problem I think that the engine precompiled information for IOS is lost or broken and yes I tried even reinstalling my editor. :frowning:

I have just encountered this problem myself. I got lucky and was able to get things going again quickly. I have no idea what the real solution may have been, but here’s what I did:

Removed all Icons and Splash screens from Project Settings > iOS (as these were the last things I changed)
Deleted these folders from Project folder

  • Saved
  • Intermediate
  • Binaries
  • Build
  • FPTest2.xcworkspace (FPTest2 was previous project name - I presume xcworkspace relates to XCode remote build)

I’ll let you know if I encounter and solve again.

Your problem was changing the icons and setting back the default ones fixed it for you. But I’m not changing anything because I’m using Blank Project and it still ask for Remote Build.