iOS App Missing Compliance in Test Flight

Hi All. I am currently developing an iOS game using UE 4.10.4 (latest at time of writing this) on a Windows Machine.

Until a day or so ago this all worked perfectly fine. Unsure of exactly what changed to make it stop working. As far as I can tell I have done all of the background bits and pieces.

Basically the issue is that when I upload the packaged IPA file to iTunes Connect (using the Application Uploader in a Mac) I get a message in iTunes Connect that the app is missing compliance. When I try to open the app on my iPad (pushed via Test Flight) it doesn’t get past the Splash Screen.


here are the settings i’m using (these were working until 2 days ago to push the app via testflight to testers)
My Packaging Settings:

Apologies if I’m being a bit too liberal with the obfuscate tool (truth be told i’m not sure what should be sensitive and what shouldn’t).

Does anyone have any clues/ideas/suggestions on why I’m getting this message? Any other info i can provide I’d be happy to.
PLEASE HELP! Again sorry if too liberal with the obfuscate.

It looks like Apple is now enforcing an encryption exemption compliance. This means I will need to update the generated plist, but you can add the following to the addition plist data in Project Settings/IOS to get around it for now:


Let me know if that works for you and I’ll make sure we get this added as an option for 4.11.


Hi Pete. Thank HEAPS for replying!

Unfortunately it causes the packaging to fail when I add that line. (Assuming i did it right?)

Also [here][2] is a link to the log file.

Let me know if i can provide anything else.

haha. Those always get me too. My bad i should’ve picked up on that too. But hey in it’s early morning right now and i haven’t had a coffee yet. So I’m going with that excuse :stuck_out_tongue:

But that did package properly. I’ll let you know if the iTunes Connect bit works.
Thanks again.

Shoot I missed a piece in what I wrote above. It should be:


Missed a ‘>’ in the previous reply.

Good news! It seems to have worked!! :slight_smile: Thank you SO SO SO SO MUCH!!
Pete you are the man!

Great. I have added this to the generated plist for 4.11. Glad it works for you.