iOS app crashing after splash

Hey guys,
Im having an issue with an app for mobile on iOS. IT crashes right after the splash screen. I’ve seen a couple people having the same problem, but their solutions didn’t work out for me, it keeps crashing.
Some info:

  • While on development mode and installing the ipa through itunes it worked just fine, on several devices.
  • I’m getting the missing push notification error
  • Tried disabling the google vr plugin, but it’s not the reason of the crash.
  • Tried adding the -x to the stripprocess argument

I’ve heard that maybe enabling the push notifications might help, but cant find any documentation on that subject.

Any solutions? I’m attaching the crashing.

Really appreciate it guys, thanks.
link text
link text

Hi PabloCo,

To get started troubleshooting your issue:

  1. Is your app set up to use Push Notifications (intentionally) in Ue4?
  2. Did you included Push Notifications when setting up your App ID, Certs and Provisions as described in the following link: Missing Push Notification Entitlement

Please respond with this information,

Steve H.

hi Steve!
No, there’s absolutely nothing on the project that requires push notifications, and i have not included push notifications on any of the certs, etc.

Here’s the link with the full crash log, apparently the crash is here:

“Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY
Triggered by Thread: 6”

Again, this only happens with the Google VR plugin enabled. When it’s off o can run without any trouble.

Edit: this only happens with Google VR plugin enabled in distribution mode, while on development mode it packages and runs just fine

Are you on a Mac or PC? Are you using a separate set of Certificates and Provisions for distribution than for development?

I’m on a mac. I am using a separate pair of cert and prov for distribution. As I said, the crash only presents itself when the Google VR plugin is enabled, disabled runs just fine on testflght.

The problem is arm64, I’m stuck with that too. :frowning:

Hi PlabloCo,

This issue has been reported as UE-35334 and is scheduled to be fixed in a future release of the engine. You can track the status of the bug from the provided link.

-Steve H.

This happens to me when I add “Support arm64”, if just armv7 is checked the app works, but iTunes requires arm64.

Hi Picios,

I have added this information to the bug report and increased the community interest.

Thanks for the feedback,

Steve H.

■■■■, we are gonna have to wait for 4.16 for this to be solved? Haha My client is gonna kill me :’(