iOS and Mac Packages crash on launch


Im attempting to package my first iOS game for the AppStore but am having some major issues with my package crashing on launch. I have tried many different solutions, such as opening the project in different editor versions ( 4.8, 4.6, and 4.7) and i still get the same results. I have tried packaging for distribution and development with no change, and I tried launching my game and it worked just fine. I also tried packaging another project (third person template) with all the different settings i tried on my other game and it worked fine.

I really need some help with this as this is a pretty big issue I’m dealing with. Your help is greatly appreciated.

Please, I really need some answers :frowning:

Your computer is not powerful enough

Open xCode and go to Window → Device and Simulators, select your device, and check the console and logs for anything useful. It may tip you off about whats going on.

You realize this is question is four years old right? Not to say your answer is invalid, I’m sure it can help out someone else :slight_smile: