Invisible 'button' actor still responds to player input

Hi folks,

I am spawning various groups of actors in the same grid locations, and switching their visibility. To put this into context, I am using the meshes as buttons which I am substituting with a category button.

My problem at the moment is that I am able to set the actors to invisible, however they still respond to clicks (/touches) when invisible.

Is there a way I can make invisible actors also not respond to player inputs?

Another way of putting this would be: I want to enable and disable a bunch of buttons using Blueprints. What’s the best way to do this?

Many thanks for any advice!

You can enable/disable or make buttons visible/invisible as part of their Behavior.

If you want to stop click events on invisible actors, just use a boolean to check if you can continue with any click events while they are visible.