Download

Invisible box-Wall all around and inside the model.

Hello, im new with UE4, and im just trying my first project.

I have a project build in Revit, witch i exported to UE4 via 3ds Max.
I have lost the textures in the way, but i guess i need to recreate them.

I used a first person shooter base for this, as my idea is to make an interactive presentation that the client can navigate on his own.

But from the start i have a big problem. The model is placed in some kind of invisible box than cannot be penetrated, an if i place the FirstPersonCamera “inside”, it cannot move at all.

Can anyone help me with this?

Thanks in advance!

The mesh will bring a collision box that encompasses the entire mesh by default. You need to edit the mesh and change the collision complexity to “Use Complex Collision As Simple.”

Do I do this when i import the FBX? I didnt find were to do this?

can i do this to all objetcs at once?

There is a checkbox that will create a simple collision if ticked. It’s on the top of the import window called “Auto generate collision”. To remove the collision double click the mesh in the content browser to open its properties. There is a collision section in the menu bar. Here you can remove the collision or add another simple collision. You can also move the collision around once you created it.

If the poly count isn’t too high would probably want to use the polygons itself as collision. This makes sense for building walls. To do this browse to the collision section in the mesh properties (not the detail panel) and set the collision complexity to use “complex collision as simple”. As DMHokie already mentioned.

This is a games engine so there are 2 types of collision

  1. simple collision is a box or another simple shape. This will be used for player collision and grenades, etc.
  2. complex collision is the actual geometry of the asset and is used for bullets, etc

That’s why it is named a bit confusing: use complex collision as simple, you want the player to use the complex collision instead of the simple collision. In ArchViz where there is no bullets or other effects it is ok to use complex collision. But if you have lets say a couch or table it makes sense to add a simple collision box or cylinder to it, especially if those are high poly.

Thanks a lot S-DOT, i will try this out.

Hi,
i get the explanation but the thing is that, when I imported the FBX, i was able to uncheck the create collision. but, no there nor then (when already imported), in the properties of the staticmesh actors , is the option of simple or complex. (All the elements of the fbx were imported as multiples items, categorized as static mesh actors, with i guess is great for then applying textures).
6a747cefd90451e54f49bd6000064497850e8327.jpeg

You have to edit the mesh. Right click your mesh and edit it in the edit window. Or click it and hit ctrl-E. The Collision Complexity is in the editor, not just in the properties window.

Thanks a lot. Super usefull, i just converted to “use complex as simple” about 180 objets (all that i imported, just to be sure) and now i can walk throu almost all the proyect.
BUT.
There still is a problem, with the doorways. Most of them i cannot go throug them. only a few work ok. at first i think is the issue was they are to narrow, but the smaller one is about 80centimetes wide. and the largest about 1 meter. and there are some that of those that i can go through with no problems. So what can the problem be?

As i modeled in revit, i exported the FBX, with only a hole, and no doors. the hole, is part of a particular wall.

thanks a lot in advanve

Never mind about that. I just scaled the firstperson to 0.7 and i can navigate the entire proyect perfectly!!!

So happy!

I had this same problem. I just disabled collisions. And now i can fly around like a ghost. Works well if you just plan on doing a arch viz showreel amd no interactions with someone walking around.