Download

Inventory System/Hotbar Not Displaying

Hey,

I’m trying to get an inventory system working in my game, using some free marketplace content (here), but I’m running into problems and it doesn’t look like the original creator is answering questions anymore.

Basically, I’ve gone through all the setup in the documentation (here) and gotten to the testing stage - the problem is, the hotboxes and the inventory aren’t displaying. The screen locks up like it should when the inventory key is pressed (preventing the player from running around while they rummage through their stuff), but the actual inventory doesn’t display and the hotboxes are absent entirely. I’ve tried comparing my blueprints to the original project, where everything works as it should, but I can’t figure out what’s different.

Right now, the game runs fine except for the inventory not displaying. There are no compiler errors, but whenever I stop a play-test, I get two instances of this error:


Blueprint Runtime Error: "Accessed None trying to read property InventoryManager". Blueprint: ThirdPersonCharacter Function: Execute Ubergraph Third Person Character Graph: EventGraph Node: Toggle Inventory Open

Here’s the code snippet that it’s referring to:

As best I can tell, the Inventory Manager variable needs to be defined somehow, but again - it’s not defined in the original code, and I don’t know what else is different.

Inventory Manager variable details in my game:
InventoryManager_FarmSim.PNG

vs the default inventory manager game:
InventoryManager_default.PNG

I’m newish to Unreal and really bad at coding, so any help is appreciated as long as you use layman’s terms lol.

I’m assuming your inventory and hotbar are on a widget, if so you can try the method in this video https://www.youtube.com/watch?v=7tVr7qFQCVY. Worked for me