Download

Inventor Datasmith Import Fail

Hello,

we are currently trying to import a somewhat bigger Inventor Assembly. The file opens clean with Inventor without any errors and we can import parts of it, but when I try to import the complete assembly I get the following error:

LogSlate: FSceneViewport::OnFocusLost() reason 0
LogSavePackage: Moving ‘…/…/…/…/…/…/Projekte/MyProject2/Saved/ProductViewer_Auto21F1CE03E433F669674BB9A859759B870.tmp’ to ‘…/…/…/…/…/…/Projekte/MyProject2/Saved/Autosaves/Game/ProductViewer/Levels/ProductViewer_Auto2.umap’
LogFileHelpers: Editor autosave (incl. sublevels) for ‘/Game/ProductViewer/Levels/ProductViewer’ took 0.462
LogFileHelpers: Editor autosave (incl. sublevels) for all levels took 0.462
LogSlate: Window ‘Choose Location for importing the Datasmith content’ being destroyed
LogFactory: FactoryCreateFile: Material with DatasmithCADImportFactory (0 0 …/…/…/…/…/…/Projekte/UReality-51QB/Workspace/Grundriss_E-Line_51QB_Yachting.iam)
LogSlate: Window ‘Datasmith Import Options’ being destroyed
LogSlate: Window ‘Message’ being destroyed
LogDatasmithImport: Warning: Failed to import ‘…/…/…/…/…/…/Projekte/InventorTest/Workspace/Test.iam’. Failed to create asset ‘Test’.
Please see Output Log for details.

But this is the Output Log and there are no details in it. The error come instantly so it is not something in the size.

Please submit a bug report to https://unrealstudiohelp.epicgames.com/s/case-community-page and provide the asset for reproduction, and our staff can test to determine the issue.

Thank you.

As this is privileged information (CAD Files) is there a way to sort out an NDA etc.?

Are you using new levels of detail in your assemblies? If so, remove all of them that you added. You can ignore the ones regarding content center parts. Also make sure you pack and go your master model to a new folder so all of the references can be imported.

My usual workflow is:

  1. complete actual drawing
  2. pack and go to new folder
  3. strip LOD’s
  4. replace any assembly instances with copies with different names (if you use complex assemblies this will help importing, but optional)

I pack and goed everything, removed any unneeded stuff, didn’t have any LODs etc. but I still get the error right away.

I can import the smaller assemblies piece by piece, at least some of them but the bigger ones throw the same error right away.

Is there a size limit implemented?

I haven’t ran into any size limit as of yet, sorry. If there are only certain assemblies that are giving you problems importing, there’s most likely something different in there that datasmith isn’t liking that isn’t in any of the assemblies that import without failing. For me, it was LOD’s, but maybe you have some position details saved? Are any assemblies using a non-master representation somewhere? Any parts enabled/disabled/not-visible?

Still can’t figure out the problem. If I export from Inventor to CAT it has the same error, if I export to DWG same error. I checked and there is only the main LOD in the parts and everything is visible.

Some parts ipt and iam I can import one by one but some exit with the same error. If I import it part by part they all span on 0,0,0 so nothing fits together.

Not sure what it could be then. Make sure you submit a bug report with your files. Epic handles sensitive files regularly so I’m sure they would be safe.

Last ditch guess, do you have any stray sketches or a part’s history rolled back at all?

Still nothing in there. I scanned for old or missing linked files etc. and it showed nothing. Already in contact with Epic on this but went the Inventor -> 3DMax -> Exporter -> UE4 way now in this. It works but is far from elegant or fast.