Download

Interpolation between keyframes (Blender to UE4)

Hi!

For some animation I have frames that should follow each other and the auto generated inbetweens just ruin the animation. Is it possible to only play the frames I set in my animation program? What fps number does the editor uses by default? How can I change that? If I have the same fps in UE4 and blender will I see the same frames in UE4 as in blender without any more inbetweens?

Thanks!

Gézu

You could set your interpolation mode to “constant” in blender, you do so in the curve editor after selecting all the curves.
But UE4 may still add some interpolation if you do anything to mess with the animation speed with in the editor (sorry IDK the editor FPS, I imagine 60fps)

Hi!
Thx for the answer. I know how I can handle inbetweens in blender, I am worried about the extra interpolation UE4 doest to the exported animation.
Meanwhile I found some hints on engine fps. By default it is 120 so it’s no wonder I get extra interpolation even for a 60 fps animation. I just wonder why does the engine use so high frame rate. Most of the games run at 60 fps.

I think you need to look at the compression settings in the FBX export settings.

I would suggest up-scaling your animations to match the editor (set Blenders FPS to 60), and every single frame needs to be key framed before export. (then adjust the compression settings on export, experiment with different settings to see what preserves your animation best)

If you still want to limit UE4’s FPS, you can try this:
https://answers.unrealengine.com/questions/16836/can-you-lock-the-fps.html

Someone in answers need to lock FPS too, I still say it’s better to adjust your content to UE4 (it’s more work, but it always better to have high quality assets and scale down because that’s easier than scaling up, it’s a way of future proofing)

Thanks, I set Blenders FPS to 60, UE4 fps to 60 and now it seems to be working. .D

Glad it works now, good luck :slight_smile: