Hi Epic-Team,

I have experienced following error:

Internal compiler error inside CreateExecutionSchedule; please contact framework team as we need a repro for this bug!

When and how: It suddenly came up in a BP which has worked well for last week. Yesterday I spent day adding network functionality to my game and when I closed and re-openend my project hours later, it crashed when I clicked on play. I then found out that it appears during a cast to my custom PlayerController. wires had unattached themselves and when I tried to reattach them and compiled, “internal compiler error” came up.

problems it brings are rather huge: I can’t open my project anymore. It crashes on editor startup.

I had recently encountered this bug in another project which I created (UE crashes after behavior tree tests - AI - Epic Developer Community Forums). However, these two projects are almost entirely different: earlier one was a space shooter, relying heavily on Paper2D, own content and using source control (SVN). one I work on at moment is a test project with a Zelda-like top-down camera, no self-made content at all and network functionality.

Below you can see a screenshot of error. It is from other project, but it looks almost identical. A log from current project is also attached.

As I now have two projects on hold because of identical issue, I would really appreciate some help! :smiley: If I can provide any additional information, please let me know.

Hey Artax,

Have you upgraded to 4.5 Preview yet? I believe this issue has been fixed. If you haven’t already, can you create a copy of your project in 4.5 Preview, reconnect and refresh nodes in BP, and try again? If project doesn’t open, can you try opening a backup that still opens in 4.4 and try copying and opening that in 4.5 Preview? Thanks!

No, I hadn’t tried 4.5 yet, project was created completely in 4.4.3.

But I just installed 4.5 and hell yes, I can open game and broken BP again :slight_smile: I will try to work with it (I’m still a litte uneasy abouth this because this error made me tear my hair out for past few weeks) and report back if issue returns!

In case it doesn’t: Thanks a lot for fixing this bug! :slight_smile:

I’m glad you got it working again! Please do let us know if you run into any of these problems again, including nodes getting disconnected, even if it doesn’t cause a crash. Thanks!

At your service! :wink: