Internal compiler error inside CreateExecutionSchedule

Error Internal compiler error inside CreateExecutionSchedule (site 2); please contact the framework team as we need a repro for this bug!

Error The property associated with AxisValue could not be found

Error The property associated with AxisValue could not be found

Error The property associated with AxisValue could not be found

Error The property associated with AxisValue could not be found

Warning [4077.07] Compile of FPV_Character failed. 5 Fatal Issue(s) 0 Warning(s) [in 25 ms]

This happens to me when I try to compile from the blueprint window after hooking up a WhileLoop for a battery powered flashlight I’m trying to make. If I don’t hook up the while loop it compiles fine.

I should note that it only errors if I compile it from the blueprint window. If I don’t use the blueprint window compile button and instead just go straight to play in editor then it compiles and plays fine. It even shows up with the green check mark when I go back and look at the blueprint window afterward.

Hey Arkiras,

Sorry for the delay in response to this issue! If you are still getting this error, could you provide a screenshot of your blueprint setup?



Hey, sorry but I cannot. Since this wasn’t a showstopping problem for me I just kept working without compiling from the BP window and eventually it went away. I ran into the same error a few times but worked around them the same way.

Unfortunately at this point even if the error happened again, my blueprint graph has become pretty large and I don’t think I could post it without spending 40 minutes stitching together images unless you only needed a portion of it (or theres a better way to output a picture of the BP graph that I’m not aware of?)

Hey Arkiras,

If you do happen to get this error again, save a copy of your blueprint in that state and make a copy of it to store somewhere else on your hard drive. Then just bump this thread and attach a copy of that asset, if you can. In the meantime, we’ll go ahead and mark this thread as resolved (any bumps to the thread will un-mark it as resolved, so no worries).



I got this error recently too, and managed to reduce the test case. It’s not a steady-state error. Macros like ForEach, ForLoop, etc, seem to get corrupted when a downstream node has an error, and the only way to fix the upstream macros is to recreate them. Deleting the node that introduced the error does not fix the problem!

The problem node for me is SpawnActor with a runtime-specified actor class, and the actor being spawned has ‘exposed on spawn’ parameters. It seems the way this problem is exposed (for me) is to corrupt all upstream macros.

Hey clord,

If you are able to reproduce this issue, could you provide screenshots of your blueprint setups you are using or attach the test assets that recreate the issue?



Hi Steve,

I also got this problem. It happened when I switched the actor which was to be spawned from a “Spawn Actor from Class” node to a new actor, and then re-attached the nodes to its exposed parameters.

The parameters matched the ones of the actor that had been selected before, but once I pressed compile, the error popped up. (It didn’t show up when I simply exchanged the actor, then pressed compile.)

I have a back-up of the project in question. I’ve tried attaching the respective blueprints to this answer, but it keeps telling me the file type is invalid. If you let me know how I can provide the respective files, I’ll happily do so.



The nodes that got corrupted were the entry events (EventTick, EventAnyDamage, EventActorBeginOverlap)


Build 4.1.0 - 2053896

100% Repro:

  1. Create a blank project
  2. Create two blueprints (I used actors)
  3. Add and expose two identical parameters (e.g. one bool, one int) to be editable and available on spawn on both actor blueprints
  4. Add an empty pawn blueprint
  5. In the empty pawn blueprint, create a Spawn from class’ node, an ‘event begin play’ node, a ‘make transform’ and connect it all to the spawn node
  6. Select one of the first two blueprints to be spawned
  7. Create input nodes for the parameters (I used ‘random bool’ and ‘random int’) and connect the pins to the parameters
  8. Compile
  9. Switch the spawn node to the other of the two actor blueprints
  10. See how the connectors to its parameters are removed
  11. Reconnect the parameters to their input nodes
  12. Try to compile
  13. See the error message “Error Internal compiler error inside CreateExecutionSchedule (site 2); please contact the framework team as we need a repro for this bug!” / Warning [0698,44] Compile of mypawn failed. 1 Fatal Issue(s) 0 Warning(s) [in 1 ms]

I get this issue quite often in the prototype blueprints I do, so switching it to code instead (I like the ability of prototyping BTTasks with with BP as it requires no restart of editor).

I have seen this in after foreach’s nodes mostly. However I don’t have any clear reprocase, if abeccu’s reprocase doesn’t work, I can take some time to try to create a more minimalistic reprocase.

I am also getting this error.

Here are the screenshots of the macro in question. It does seem like some sort of corruption issue because it happened when a macro upstream from it threw an error, previously this macro was working just fine.

Adding more info: I ran into this too. Restarting the project fixed it somehow.

Hey abeccu,

Thanks for your repro steps–we were able to reproduce this internally and have filed a defect report to have the framework team fix this up!


I got this issue too. It happened after UE4 crashed and one of my BPs became corrupted. I have narrowed it down to the spawn actor being corrupted and like was said previously, it corrupted all the nodes after it too. Recreated the spawn actor node didn’t fix the issue in my case.


I’ve been having a similar issue to this with one of my blueprints the attached zip file has the .uasset file in it. This asset was working fine but when restarting some of the connections are being removed and I’m getting the error referred previously in this thread.

The delta second property referred to is from event tick I can fix the asset by cutting the contents of the file and then pasting them back in place which causes it to work for this session but once I have resaved it (regardless of the changes I have made) it becomes corrupted so when I restart the editor I get the following crash.

The attached zip file has the asset before and after saving - any help you could give with this would be invaluable. I’ve recreated the project from scratch multiple times and am now moving the functionality to C++ but would ideally like to keep it in blueprint if I can.



Happened to me just now, but I think I identified the cause. I’m using 4.6.1.

I was formatting text to print out two values to screen. I used the standard Format Text → Print String nodes.

Anyways, when I was typing the parameters, I did x first via “x={x}”. It created the X node to connect to it. Then I changed it to “x={x}, y={y}” and somehow the x part got nuked, and just a y node appeared to connect to it. Then I typed it again, and this time, both nodes showed up, but in reverse order “x={x}, y={y}” in the format, but y and x nodes in that order. I wired up the rest, and boom – compile error.

Restarting the project fixed it and the x and y values were in the proper order and it worked.

Hello morness,

I was unable to reproduce this issue with the steps provided. I also tried the old reproduction steps and this issue appears to have been fixed. I have a few questions that will help narrow down the issue.

Quick quesitons:

  1. Can you reproduce this in a clean project?
  2. Could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of the blueprints that may be involved in this issue?

I just ran into this error. I am using 4.13 It is happening on a very simple blueprint for me. I was copying some timelines around, to do some changes to the bp and have a backup just in case. Then when I try to compile, an unrelated custom event triggers the issue.

have tried restarting the project, as well as redoing the custom event with a different name but it still gives me the error.

And when I make a new custom event and plug it in to those variables, I get an issue.

Is there a work around to this issue? I can’t develop my game out if this BP keeps failing to compile.

Hello Motanum,

I believe that this is a separate issue from what was reported on this thread. Could you create a new thread for tracking purposes and post a link in a reply here so that I can follow up?. In the new thread could you answer the questions below.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?