Internal Compiler error Inside CreateExecutionSchedule(Site 1)

Hello, while I was making a macro to extract the data of a array of structs that is contained inside of another array of structs I came across this error.

“Error Internal compiler error inside CreateExecutionSchedule (site 1); there is an issue with node/pin manipulation that was performed in this graph, please contact the Blueprints team!”

It only gives me this error though if I connect the Enum to the output, if I connect all of the other ones though and leave the enum dissconnected it is perfectly fine. Not sure if there is something I am misunderstanding here or if it is a bug.

Hi ,

Thank you for the report. We have assigned one of our technicians to investigate your issue and they may post here with additional questions or comments.

Hi ,

Does this work if you create it in a function instead of in a macro? Additionally, make sure that the enum you are getting from your struct matches the enum type of your output pin.

Sorry for the delayed response but I can confirm that it doesn’t throw the error when used in a function rather than a macro and that the output pin is the same as the struct enum. I even removed the output pin and just dragged the struct break’s enum to the output to add it that way and still threw the error.

So I tried to delete the output node and make a new one and it worked for about 20 minutes then it started throwing the error again but only when I attach the Enum

Is the Enum a custom made enum or one pre-existing in the editor? Would you be willing to send me a test project that is exhibiting this behavior? I’ll be happy to take a look.

Custom made enum and I will try to get a test project togethor for you here soon.

Ok so two things;

  1. I have a tesst project with the Error but not sure how to send it.
  2. It appears to only throw the error if I removed a output node. example I have a boolean and the custom Enum. When I remove the boolean from the return node it starts throwing the error after a recompile.

If you put the project in a . file you should be able to upload that directly here. If not, you can upload it to a dedicated FTP service such as dropbox and share the link with me, I’ll be happy to take a look and see what may be occurring.

Sorry for the delay, had a busy last few days! But here is the dropbox link to the project containing the error.

Hi ,

I downloaded your project and can see the error, however I want to make sure I understand the steps you took so I can reproduce this on my end. Can you walk me through what steps you took to get to this point?

Step 1: Create a struct containing a custom enum

Step 2: Created the Data actor named “Container”

Step 3: Inside container put a array of the struct that contained the custom Enum, resize array.

Step 4: Create the actor that uses the Data actor, “Enum_Usage”.

Step 5: Open “Enum_Usage” and make it spawn the data actor.

Step 6: Create a macro that takes in the actor that was just spawned (Container in this case) and return the Custom Enum contained inside.

Note: As I stated above I noticed the error only throws if inside the Macro I remove a return value that was ccreated before the custom enum.

Step 1: Create a boolean return value for the macro (Any type of variable should cause it though)

Step 2: Drag the Enum pin we got from the spawned data actor to the macro return output

Step 3: Compile

Step 4: Remove the Boolean Output pin (Or whatever variable you chose)

Step 5: Recompile and the Error should throw.

Hi ,

I was able to reproduce this on my end and have entered a bug report, UE-19717, to be assessed by the development staff.

Alright awesome! Wasn’t that big of a deal but wasn’t sure how deep it went.
Thanks again!

Hi, I had the same error. I happens sudden after some manipulations in my blueprint. I also tried to switch the project for higher version and etc nothing helped.


I started connect and disconnect my nodes. Last time I worked in my macro that goes to tick, when I switched it off everything goes fine. At las I have found a small Branch node that cause the crash.

It looks a little bit different than the other nodes, I would said twice contrast. I recreated the same and everything started work.

What I have made?

Preveously Ctrl + x
Than Ctrl + z … Ctrl + z… Ctrl + z… Ctrl + z… and Ctrl + v
Somehow bluprint created itself twice inside or something simular and tha cause this crash.

I will attach the screenshots