Interface Events Not Showing in Menu

I have tested this on several different projects using v4.5 and experimental editor functions are enabled. Disabling them made no change.

When I create a A blueprint that implements an interface containing function declarations with no output nodes, I am not able to find event nodes that should be created in host class even though I can access functions themselves. This means even though I can call functions I can’t edit them. If I add a return value, I can call them and edit them, but I still can not generate a default event for them because it appears that one already exists that has already been created.


As a work around, I added a bool to return values for each of functions. I am still not able to create events(which seems like may have been a deprecated method of doing things), but at least I can edit function graphs now.

Hey RAVaught,

Try disabling experimental Use New Blueprint Menuing System. I checked this and it seems I cannot find Event for an Interface Function either, even when searching for it by name. After disabling that feature, it appeared as expected when I searched for it.

new system was put into 4.5 to help deal with some of issues with context menu, but it doesn’t fix every issue and this appears to be one of those weird examples. I can confirm that this functions as expected in our internal build, and should work correctly in next release. In meantime, you may need to turn off this experimental feature now and again if a node does not appear when you expect it to.

Hope that helps!

1 Like


I toggled off experimental menu system and function events still don’t show up (see image). I also tried a full restart, with no joy. If this is fixed in upcoming release, I will set it as resolved for now. Thanks for quick reply.


Are you in 4.5.0 or 4.5.1?

4.5.0 I won’t be able to make move to 4.5.1+ for at least another week.

Ah, okay. Let me know if this still occurs once you update and we’ll look into it a little deeper.

I can verify this is still occurring in 4.5.1 for me, cannot access events in a blueprint with interface implemented, and without any returns UNLESS i disable new bp menu system. pretty frustrating, as it hinders experimentation that was previously very solid and helpful. Love system though, not having too much of a gripe :smiley:

Nah, not too big of an issue unless you are new and don’t know about it, or you have to keep switching back and forth to get Interface events and Cast To nodes.