Interface bug 4.12 and 4.13

When restoring previously opened Blueprints, all graph windows are re-arranged at bottom and the viewport is set as main. This can become annoying since you have to re-arrange all of your graphs in the editor.

Hi Vladone,

Please describe how to recreate this in the Third Person Blueprint project, step by step, so that we can reproduce the issue on our end.

Thanks,

Steve H.

Hello,
I’ve tested the issue in both 4.13.2 and 4.12.5

The steps to reproduce the bug are the following:

  1. Open a Blueprint;
  2. try to move one of the graph tabs in the middle, basically un-dock it and reposition it in the middle;
  3. close the Editor after re-arranging the tabs in the proper position;
  4. when you open the editor the image should be like the one shown in the screenshot:

Thing is, once it gets like this, the issue reproduces in all the projects.
At some point it didn’t appeared. But now I did the un-docking of graph tabs, and the windows stay in this split screen position. Somebody new to Unreal may not interpret this as a Bug :slight_smile:

Also, open multiple blueprints afterwards to see how the effect continues.

Please post a screenshot of how you expect previously opened Blueprints to be arranged upon reopening the project -thanks!

I think the most expected would be see first the Event Graph, since you open a blueprint to script / program inside of it.
Attached screen:

Hi Vladone,

I was not able to reproduce the issue in UE4.13 following these steps:

  1. In UE4.13, Open a blank Third Person Blueprint project in UE4.13
  2. Open the ThirdPersonCharacter Blueprint and arrange tabs as shown from above:

  1. In editor settings, make sure the following are set as shown:

  1. Close the project and the Launcher
  2. Reopen the Editor and select the appropriate project

RESULT: ThirdPersonCharacter Blueprint window opens the exact same way as when it was closed, but undocked.

Let me know if these steps do not represent the bug you are reporting and, if not, please let me know what I need to change to accurately reproduce the issue.

-Steve H.

Hmm, strange

The only thing I had different in my Editor Preferences was “Restore Open Asset Tab on Restart” checkbox.

Yep, it fit’s my options …

Does this mean selecting this option resolves the issue?

Yep, we can put this as solved for now :wink: