Download

Intellisense Suggestions not working for Macros in Visual Studio 2019

I have the Unreal Engine 4.25.3 installed. I am brand new to game development with c++ and c++ both. I download the game dev with c++ workspace in Visual Studio 2019 and created a new project(game) in Unreal Engine. When I write #include “Components/StaticMeshComponent.h”, there is no suggestion box for “Components/StaticMeshComponents.h” but I can see my own character.h files. The #include suggestion box also works in a very finnicky manner, it only shows up sometimes. Here i am trying to get into game development with such passion and things like this really discourage me. Please help me out.

This has been a common issue for many people since the release of 4.25. I tried to solve this without luck. I did my research on this a few months back, so my information may be old.

You could try VS 2017, compiling the engine from source (this isn’t likely to solve it, but a few reported it worked) or you could try Rider for Unreal. When I ran into the issue, I went for rider and haven’t looked back since.

https://forums.unrealengine.com/deve…esh-components

I’m using **Visual Studio **2017 version

IntelliSense doesn’t seem to work in any editor now. It works a little bit in VS Code, but every IntelliSense operation fails (IntelliSense is unresponsive with Unreal Engine 4 · Issue #5849 · microsoft/vscode-cpptools · GitHub) with 50% chance, so I don’t rely on it anymore.

I strongly advice against using VS2017/2019, it’s very slow and clumsy pile of software.

You hit that on the head, what joke this is. Maybe someday epic will fix the header issues? Amazing!