Download

Intellisense not working UE4.25

I just downloaded the new version and started a small project. I am getting a lot more crashes in the editor than I am used to, but more frustratingly, I get no Intellisense in VS 2017.

It has been a few months since I worked in UE4, but last time I did, I didn’t have any problems with VS. Is there something new that I have to do or set up to get this working again? If it isn’t related to the new update, are there any suggestions on how to get Intellisense running again? I don’t see a lot of hits when I search, so I assume its either obvious or uncommon. I am hoping for the former =)

Thanks in advance!
Eric

I’m experiencing this as well.

I managed to get it sort of working by adding paths into [Project Properties>NMake>Intellisense>Include Search Path]. However I feel like it’s a workaround and not actually how one should fix it, not least of all because it now takes ~10s for predictions to appear!

Does anyone have an actual fix for this?

I’m getting the same issue, you can get it to working by including a header from Engine. But it feels like a work around because its finicky. I opened an issue also. I am surprised more people are not encountering this.

Edit:
If you Generate the Visual Studio files from right clicking the Unreal Project file it will also correct the issue without any weird stuff happening

what did you include into the search path ?

k I did File/Refresh Visual studio project in my UE project and it fixed everything

2 Likes

This works better, thank you!

For those who still can’t make it work, try replacing the defines value from c_cpp_properties.json in your project with the following defines value: ue422-defines.txt - Google Drive
Use Find (CTRL+F) and search for MyProject, and replace it with your project name.
(This defines value is being copied from a project in UE4.22, if you have UE4.22, you can straight copy it from there)

Thanks bruda it worked

Damn, I didn’t even know that exists. Thanks alot, citizen, that fixed all my “symbol not found” problems in VS

Thank you!

i write #inc show #include 15 second later i don’t understand

Note the “WIN” definitions in there that must be swapped out for Mac. I’m not sure what is exactly right, but I deleted all the “Win” entries and it seems fine.