Intel 13700k core usage issue


I recently build a new computer
64Gb DDR5
Radeon 7900XT

I notice during building source of UE5. Only 8 core are used.
The 13700k have 8 core + 8 hyperthreaded code for a total of 24.
Is see the same issue whith shader compiling.

I already try to change the build configuration in BuildConfiguration.xml, I force all core, remove RAM per core limitation, but nothing change.

Anyone have information about that behaviour and how to fix it ?



I had the same problem with my 12900K.

When the Unreal Build Tool spawns subprocesses to build, it uses ProcessPriorityClass.BelowNormal. And, when your CPU has efficiency cores (like the 12900K, and 13700K), .Net (or the Windows kernel?) will only schedule those processes onto efficiency cores, never performance cores.

You have two options that I know of to work around this:

  1. Set the process priority to Normal or higher in BuildConfiguration.xml (read more about this here: Build Configuration for Unreal Engine | Unreal Engine 5.1 Documentation).

  2. Disable your efficiency cores in your machine’s BIOS, so they can’t be used at all.

Option 1 seems like the more attractive one, since it leaves your efficiency cores available. But, for me, running the compilation at Normal priority meant that all other running programs were basically unresponsive until the compile completed.

I think either option should work, but each has its drawbacks.