Intel 12th Gen Shader Compilation Process Affinity

Hello everyone!

Currently 12th gen I7 12700k uses only e-cores by default to compile shaders. There is a way to manually exclude e-cores for every shader-compiling process in windows task manager - set affinity to be only p-cores (for me this is CPU0-CPU15). Usually when I start new project I do that when it compile shaders but it takes time and it is not how it should work. The power and speed of 12th gen processors should be applied automatically for such tasks.

Is there any workarounds, .ini commands to force Unreal Engine to always use p-cores for shader compilation?

I’ve got the same problem with i9 12900k, Unreal is using only 8 e-cores for light building and shader compiling. It would be awesome to use the 8 p-core + 8 e core and threads for this tasks. Any solution someone ?

Is this only an issue with Windows 10 or will it also be an issue with Windows 11 which I believe has an updated task scheduler to deal with hybrid processors that have differing core types?

Hello,
I was running Windows 10 and had the sames issues : Windows 10 was using only E-cores instead of all cores for Unreal (and some other programs).

Solved when I updated to Windows 11 : It uses all cores now (p+e) for shaders, building lights, etc.

1st solution is to go for win 11
2nd solution if you want to stay on Win10 but use all cores, you need to use a software like " Process Lasso" to force windows to work with all cores.

1 Like

I’ve same issue 12700k on Windows 10.
I just disabled E-Core in UEFI(BIOS) then solved.

my cup is 12700 and I have same problem as you
hope epic see this and fix it soon