Download

Instancing uv co-ordinates

Hi all,

I’m needing help, I’ve created a material instance for some railing assets and I can’t seem to find away to make an “adjustable texture co-ordinate” for UV Tiling?. Some railings are very long and some are short, rather than break up the longer pieces im trying to create an adjustable texture co-ordinate for each different size asset. Can this be achieved?

Hi,

Step 1: Create two scalar parameters for U and V to be edited in the instances.
Step 2: Take the TextureCoordinates node.
Step 3: Use the Mask or the BreakVector2D node to get access to the U and V values.
Step 4: Multiply the values with your parameters. (leave the tiling settings in the TextureCoordinate node at 1)
Step 5: Recombine the values to a new 2D node by using the append node.
Step 6: Feed that node into the UV pin of the texture sample…

Cheers,
Klaus

Thank for you reply Klause, however im not understanding a few things. 1st I can only find a “breakoutfloat2dcomponent” node is this what u mean by breakvector2d node? and secondly im not sure what pins go where, I have “textcoord” into “breakoutfloat2dcomponent” scalar U and V nodes into the “multiply” and the “append vector” into the texture node, the output on “multiply” and “breakoutfloat2dcomponent” are not connected and don’t know there they go?

Hi,

Yeah, thats the node i meant.
I was reciting that from memory :slight_smile:

It should look like:
6d9b7166b21a66d8c8847c0613aa4a4ef814bece.jpeg

Hope that helps :slight_smile:

Ah thanks that great!, last problem I have a “texturesamplerparameter2d” not a “vector3” it turns my texture to grey colour and doesn’t compute my texture normal??

It should work with a parameter texture the same (I used a texture as well, not a vector3)
Show me your setup. Maybe thats more obvious then where the problem is…

Won’t have the chance until off work again in 2 days, but i’ll double check my connections and if it’s not fixed i’ll post my layout. Cheers KVogler

It works, the UV parameters were at 0.0 so I forgot to set them to anything but. So thanks again for your help, much appreciated KVogler :slight_smile: