Instanced static meshes not culling

I have instanced static mesh objects created by a blueprint. The culling distance is set on them, but no culling is taking place. I’ve seen that this may either be a bug or an issue with a setting in the material. Is there a trick to get HISM to work? (UE4 4.18)

I believe this is how instanced static meshes work. They’re all sent in a batch. If one is rendered then they’ll all be rendered.

That’s a shame is that’s true. Because foliage is instanced and it does cull.

sorry for the necro but this thread came up a couple of times when i was trying to get this to work and i thought i’d share a solution.

so to make the instanced mesh culling settings to work you need to use a “PerInstanceFadeAmount” node in the material used on the meshs you’re instancing (as seen in the image below). Note that the blend mode has to be Masked or Transparent.