Instanced Static Meshes created by using a blueprint are not showing any meshes when using the Play: Stand Alone Game

It shows the mesh in all the other view modes and in the editor but not when playing in standalone. It works in 4.16.3

Blueprint is using the [Add Instance node] with an [instanced static mesh] imputed into Target and just a change in Transform.

Hi Andrew,

Thank you for the report. I was able to reproduce this behavior, so I’ve created JIRA UE-48228. Our developers will be investigating further. Follow that link to monitor the status.


I did trace the cause of the problem: 4.17 severe 'Mesh Killer' bug - Asset Creation - Unreal Engine Forums

It appears to be fixed, but not yet pushed to the repo. Is the fix small enough to be posted here?

I think I may have the same issue after going from 4.14.3 to 4.17, but in c++.

I’m using an array of UInstancedStaticMeshComponent to add, update and remove instances via methods like UpdateInstanceTransform. I don’t know why, but when I do a specific action in-game and call UpdateInstanceTransform on a single UInstancedStaticMeshComponent , it seems to remove most of all instances of all UInstancedStaticMeshComponents. The only way I could see this happening is if the instance array and indexes were changed following a RemoveInstance, but I’m not doing that. Also, like in this post, I only see the problem in standalone game mode, not in the editor view. So, that leads me to believe that this is a bug. Could this be related to this blueprint issue? Is there any fix incoming? I updated to 4.17.1, but no luck. Thanks.

Hey ItBurn, if you look at the link in Speedy37s post they said it should be fixed in 4.18.

When I package my project, I’m still having the issues, but I actually get even more issues that aren’t there in Standalone mode. Now if I create new mesh instances when playing, after a point they start flickering, moving, appearing over other instanced meshes and getting invalid transforms.


This is a pretty important problem as I can’t test anything. Reverting to a previous version would be a big headache and 4.18 is really far away.

Lol, same problem)
But HierarchicalInstancedStaticMesh work fine in Stand Alone

Hierarchical does work better for me in Stand Alone, but they still have massive issues when running the packaged project.

Yeah, i noticed this too, so, already revert to 4.16. And happy with instances)

Hi can you try with 4.17.2 to see if it improve things, and if it’s not fixed, some fixes had to go in 4.18, but i could provide you with CL# or Github# so you fetch directly the changes but it come with greater risk as it’s not QA approved.

I just tried 4.17.2 and it didn’t solve the issue in standalone mode. Not only that, but the first time I updated the transform of an instanced static mesh, the editor froze for a good 10 minutes. I hope it’s not going to do that every first run… I didn’t try packaged.

edit: The freeze happens regularly, but I can’t figure out what sequence of events brings it. It’s always when I update the transform.

I’ve had the same issue in Standalone mode, but the v4.17.2 update seems to have fixed it in my project. Packaged versions are working fine as well.

Strange. Are you using blueprints or c++ to create your instanced meshes? Maybe it’s fixed for blueprints and not c++.

ItBurn if you use Blueprint is should be fixed, as for C++ and with CreateDefaultSubObject code path, this had to go in 4.18 as it imply interface changes. It should be available quite soon in 4.18.

That could be it. There is no custom C++ code in my project.

Just tried 4.18. It works! At last.