Instanced Static Meshes are still colliding with character when I set to No Collision

I just had this working with regular static meshes but switched to instanced so I can have multiple of them. They are in a blueprint and I have component replicates set to True. I have them switch to No Collision at a certain point in time and then its like they have some collision which bugs the character out when he tries to walk through them. I have them invisible so its a weird glitch. I’m at a loss, anyone?

Ok, well for some odd reason, this only works if I set the collision preset to no collision in the blueprint. Even though I am setting it to No Collision in the blueprint script, it wouldn’t work. But setting it in the details panel first and then setting it to block when I want it to block works. Weird