Instanced Static Mesh crashing when hitting play

Hey guys,

i am creating a few hundred buildings via blueprint. Witch add static mesh component everything works fine, but when i replace the nodes with “add instance” everything works fine too, until i hit the play button. Then the editor crashes with the following:


Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: FromInst->OwnerComponent.Get() == NULL [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\Engine\Private\PhysicsEngine\BodyInstance.cpp] [Line: 2539]

KERNELBASE + 37901 bytes
UE4Editor_Core + 3092349 bytes
UE4Editor_Core + 1597688 bytes
UE4Editor_Core + 1479058 bytes
UE4Editor_Engine + 14028738 bytes
UE4Editor_Engine + 4413679 bytes
UE4Editor_Engine + 4230785 bytes
UE4Editor_Engine + 4236415 bytes
UE4Editor_Engine + 1444069 bytes
UE4Editor_Engine + 1653288 bytes
UE4Editor_Engine + 1585232 bytes
UE4Editor_Engine + 4975247 bytes
UE4Editor_Engine + 10031866 bytes
UE4Editor_Engine + 9904864 bytes
UE4Editor_Engine + 3804899 bytes
UE4Editor_UnrealEd + 4271756 bytes
UE4Editor_UnrealEd + 4561611 bytes
UE4Editor_UnrealEd + 4660963 bytes
UE4Editor_UnrealEd + 1801811 bytes
UE4Editor_UnrealEd + 6686342 bytes
UE4Editor!FEngineLoop::Tick() + 3876 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:2214]
UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:131]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Anyone got an idea? I really want to use the instance because it has a much better performance.

THX! :slight_smile:

Any ideas? :slight_smile:

Hi hazzardous1984,

Please do not bump threads that have not gone unanswered for 4 or more days. This clutters the answerhub and makes it more difficult for us to help anyone. Can you please post your crash logs here, these can be found at the filepath:

\Unreal Projects\PROJECTNAME\saved\logs\

Additionally, as mentioned, have you been able to reproduce this in a blank project with no additional content or is it limited to one project?

Can you share an image of your blueprint? Do they work on a new blank project? Have you tried using them on a different blueprint? I have recently used them and they worked just fine. If you can share your blueprint (without the assets of course) I can test if it works on my end.

Here can you find the Log:

And here you find the BP:

Tested it in a “blank” 3rd Person template with startercontent as meshes,… still the same :frowning:

Hi hazzardous1984,

Unfortunately I have been unable to reproduce this on my end thus far. These are the steps I have taken, please tell me if I need to adjust:

  1. Open project with blueprint in content browser.
  2. Place a copy of the blueprint in level.
  3. In details pane, I put the number to 100 and changed the values for spacing and safe zone to 1,1,1 each.
  4. Press Play in Editor.

Right, i we use the values like 500, spacing 100 100 1000 and Safezone 20000 15000 4000. And then, after hitting play, it crashes. It looks good in the editor thou. We use UE4.6.1

And now i tried your values. Same effect, it crashes.

Can you post your dxdiag here so I can take a look?

Yes i will do that. But it happens on 7 different PC Systems with different Graphicscards etc…

Are you on 4.7 preview 4?

instanced meshes crash mine immediately. even without hitting play, in the view port is sufficient for a crash (even in the BP editor)

No i am 4.6.1 and i have still no solution for this :frowning:

Hi rodstone,

The instanced mesh crashes in preview 4 are a known issue and we are currently attempting to resolve this. Please keep a lookout for a future update, though for now we recommend using 4.6.1 as the preview is an untested build and not recommended for actual project use. It is released so that users can test and see what is coming in future releases. If you could, hazzardous1984, can you post the exact steps you are taking that reproduce the crash. I haven’t been able to see it thus far but perhaps if I follow your steps I can see what may be occurring. The more information I have to reproduce this on my end the better!

I’m seeing the same problem on 4.6.1. For me, I’ve found the problem seems to come from having a static mesh parent, then adding instances in the blueprint constructor.

This is an example actor that causes a game to crash when added to a level.

My current workaround is to make the root/parent of the instanced mesh a scene.

I had the same problem with a similar “Assertion failed: FromInst->OwnerComponent.Get() == NULL [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\Engine\Private\PhysicsEngine\BodyInstance.cpp]” line in my crash log. [UE4.6.1]

I solved the issue by changing some things in my blueprint components tab. Originally I had a Billboard component set as the ROOT with an InstancedStaticMeshComponent under it. Once I removed the Billboard and had the InstancedStaticMeshComponent set as the ROOT I no longer got the crash.

So it would appear the crash has something to do with what is set as the parent component. Hope this can help someone else figure out a solution too.

Hi hazzardous1984,

Can you check to see if your crash is similar to Sandstrikes and see if their solution helps you as well?


i tried to reproduce it and i still get this error.


Hi hazzardous1984,

Can you post a new log here for me to look at, the link you provided earlier is dead.

I had the same problem. Kept crashing on play but looked fine in editor. I also was building my instances in Construction script. Anyway, the way I fixed it is by firstly removing the StaticMeshInstance from the Component list. Then go to your Construction Script > right-click in the viewport > Add InstancedStaticMeshComponent. The relative transform is unimportant as it is currently empty anyways, what is important is the Manual Attachment Bool. Set Manual Attachement to true. Then from your Add InstancedStaticMeshComponent Return Value, get a Set Static Mesh and choose your mesh.
Now that that is set up, you can begin creating instances like you would originally with the Add Instance node, and you can set the Instance Transform accordingly.

Now this should work, and if you uncheck Manual Attachement from the Add InstancedStaticMeshComponent node, it would crash. So leave it checked :stuck_out_tongue: I wasn’t able to find a similar fix if the InstacedStaticMeshComponent is created in the Component tab. Hope this works for you and whoever else is having this issue!

Also, making the Instanced Static Mesh Component the root from the Components tab seems to work. I guess the problem is attaching this component manually outside of the components tab