Download

Installing UE5 Early Access on Unbuntu Linux fails.

So I gave the UE5 early access install a shot.
First try was installing the Epic Games Launcher. This is apparently Windows only, and tried to run under Wine 6.0. Result:

This is probably due to some missing DLLs, and with enough searching for DLLs for Wine, can probably be bashed into running. “Error code SU-PQR1603” is a bit vague. Says contact support, and so, you’ve been contacted.

OK, plan B, download the sources.

> sh Setup.sh
Fixing inconsistent case in filenames.
Setting up Mono
Checking dependencies...
Updating dependencies: 100% (70998/70998), 12659.1/12659.1 MiB | 9.72 MiB/s, do
Result: 0
Register the engine installation...
Setup.sh: 44: pushd: not found

Ah, needed to say “bash Setup.sh”, or “./Setup,sh”, not “sh Setup.sh” in the instructions. Old “sh” doesn’t have “pushd”. With that fix, we get to

No third party libs needed to be built locally

**********  SUCCESS ****************
Setup successful.

After that, “make” ran fine.

Found the executable, “UnrealEditor”, and launched that.

Warnings:

Many of:

[2021.05.26-19.49.56:404][ 0]LogDirectoryWatcher: Warning: inotify_add_watch cannot watch folder /home/john/projects/ue5/UnrealEngine-5.0.0-early-access-1/Engine/Content/Editor/Slate/Animation (errno = 28, Out of inotify watches, increase user.max_inotify_watches)

One of

[2021.05.26-19.55.30:350][ 0]LogModuleManager: Warning: ModuleManager: Unable to load module 'TimeManagementEditor' - 0 instances of that module name found.

Thousands of:

[2021.05.26-19.56.09:780][433]LogSlate: Warning: Slate: Had to block on waiting for a draw buffer

Using about 12GB of 32 GB at that point, not swapping.

That worked, and I was able to create the sample “third person” project.

Project creation produced the message:

Failed to import '/home/john/projects/ue5/UnrealEngine-5.0.0-early-access-1/FeaturePacks/StarterContent.upack'. Failed to create asset '/Game/StarterContent'.
Please see Output Log for details.

But the sample project did get created and will Play.

So, looks like the Linux target for UE5 is basically working, but needs some cleanup and polishing.

(Ubuntu 20.04 LTS, Ryzen 5, NVidia 3070, 32 GB RAM…)

I was able to build it on my ubuntu 20.10 latest without problems, building procedure is exactly the same like with ue 4:

In short, you’ll need to:

  1. download and extract early-access version from github (see link)
  2. I did change the owner of the extracted folder+subfolders to the user I’m logged in with so I have full read and write access.
  3. enter the folder you extracted the engine to
  4. run “./setup.sh” inside the folder
  5. run “./GenerateProjectFiles.sh”
  6. run “make” (this can take about an hour)