Installation error ,code from github in ubuntu

i am trying to install ue4 from github following these instruction
unreal engine 4 | The Ubuntu Addict

in terminal

cd ‘unrealengine’

./Setup.sh

sudo apt-get install mono-reference-assemblies-4.0 mono-devel

./GenerateProjectFiles.sh

make UE4Editor UE4Game UnrealPak CrashReportClient ShaderCompileWorker UnrealLightmass

i get this error on this last line code…
Need help what do this error mean and how to solve it

Building UE4Editor… Using clang version ‘3.8.0’ (string), 3 (major), 8 (minor), 0 (patch) Creating makefile for UE4Editor (no existing makefile)

Failed to read dependency cache: Access to the path “/home/heloow/Desktop/UnrealEngine/Engine/Intermediate/Build/Linux/B4D820EA/UE4Editor/DependencyCache.bin.buildmutex” is denied.

ERROR: System.UnauthorizedAccessException: Access to the path “/home/heloow/Desktop/UnrealEngine/Engine/Intermediate/Build/Linux/B4D820EA/UE4Editor/DependencyCache.bin” is denied.

at System.IO.File.Delete (System.String path) <0x7f48ea55a100 + 0x0015c> in :0

at UnrealBuildTool.FileReference.Delete () <0x41725710 + 0x0001b> in :0

at UnrealBuildTool.DependencyCache.Load (UnrealBuildTool.FileReference CacheFile) <0x41725290 + 0x0020f> in :0

at UnrealBuildTool.DependencyCache.Create (UnrealBuildTool.FileReference CacheFile) <0x41725080 + 0x000ab> in :0

at UnrealBuildTool.UnrealBuildTool.RunUBT (System.String[] Arguments, UnrealBuildTool.FileReference ProjectFile) <0x41702dc0 + 0x017cb> in :0

Makefile:188: recipe for target ‘UE4Editor’ failed make: *** [UE4Editor] Error 5
Product Version: Not Selected

Hey Timilsina-

I noticed that you posted this issue here as well: Make UE4Editor UE4Game UnrealPak CrashReportClient ShaderCompileWorker UnrealLightmass get error - Platform & Builds - Unreal Engine Forums. I will be closing this post in order to focus discussion of this topic in a single location.