Download

install unreal 4.24 issue.

i been trying to install unreal 4,24 and it seem i keep getting this message, now i have successfully install unreal 4 in past but this time it seem i have exceeded the path length witch is new to me. is this new for others that trying to install unreal 4.24?

Make sure that the location you’re trying to install it to is not too long, if the actual text of the path is too long then it can’t save to it.

Trying to install several times. but failed to install…showing some error :frowning:

I just had the same problem.

I got it to work by removing some letters from some of the longer folder names, including an empty space in “Epic Games”, and then it suddenly worked.

I have installed other ue4 engines on a different drive where the path names also are long, but have no empty space in any of the folder names, so I have a feeling that might be the culprit.

It’s my first time trying to download UE I tried last night but then I canceled the download and I decided to do ti today but now this message is showing and I tried clicking on it but nothing happens and now I can’t download UE. What am I doing wrong?

I get the same problem like raptortrain. Please can somebody explain it to me: Why can I install the UE4 4.22.3 in the basic path “E:\Program Files (x86)\Epic Games\UE_4.22” but UE4 4.23.1 and UE4 4.24.3 not? That is the same path length! The only difference is the last character of the path, it changes to …\4.23 or …\4.24. The preview version of 4.25 works for me, but I want the last released stable version.

There may be folders that it has to create that would go beyond the max limit of the path length.

So… @darthviper107, a few questions then based on the above statement.

  1. Whats the max limit to a file’s path size??
  2. Whats the default path Unreal installs to naturally.
  3. What’s that default path’s size for Unreal’s default install location… and
  4. What’s Your path and path size for Unreal 4.24

if its anything different than say Haio’s “E:\Program Files (x86)\Epic Games\UE_4.24”, then its different that the default path epic installs to.
I too am getting the same Error, and I have a 4.21 version installed in the same default location but 4.24 will not install due to ‘path size error’… makes me chuckle.

if there are new folders that were introduced, that causes the default path that comes with Epic’s default install of unreal to be too long, that’s… probably on your end, not ours i’d think.
thus a bug me thinks. not a blocker, but annoying nevertheless.

The max windows path length is 260 characters
I don’t know what the default path is, I install mine directly to a folder on the drive rather than in Program Files.

Also, I don’t work for Epic, so it has nothing to do with me.