Install UE button greyed out

Hey, so as the title says, I recently moved to a new computer that I used the engine on without any issues, but now can’t install Unreal Engine at all. The Epic launcher has all installation options greyed out, tried reinstalling, repairing, even doing a fresh windows install since this was the only thing installed on it so far, but nothing works. Some suggested to just wait, but I left it open for a good couple of hours and nothing changed.

me too, new computer and all greyed out

So no movement on this issue ever? My problem too.

You should be able to click the yellow part where it says “Install Engine” and then a box will pop up with an engine version for you to install:

More info is available at Installing Unreal Engine | Unreal Engine Documentation.

That is the operative word “should”, but no clicking on the yellow part or grey part makes no difference as the interface does not allow to install any engine.
Here is a tip, rather than using an interface to install Unreal Engine - how about releasing an executable installation file (separate from the interface) where the user can install the engine without going through this troublesome procedure that does not work properly.

1 Like

Hi, I had this issue and then I realised that I have disabled the Game Library. After enabling it again I could start the engine installation.

Same issue here, bumping

1 Like

Same issue here trying to dl UE5

I don’t know what to think. Epic releases UE5, removes all available learning materials (not even the learn tab in Laucher remained) and now blocks Engine installation (clicking the yellow “Install Engine” button at top right does nothing at all.) All I can imagine is: Epic doesn’t want UE5 to be used by any and everyone.

Updating my previous post: closing Epic Launcher, then opening it again triggers the Enginde installation. Still, that’s obviously an issue that must be solved.

I was having the same issue: “+” and drop down icon greyed out.

SOLUTION STEPS:

  1. On the left pane, click on “Library”. When doing so, a yellow and striped bar should appear at the bottom.

  2. On the left pane, click on “Unreal Engine”.

Following these steps will enable you to install the engine.

1 Like

Haha, that worked for me. Thanks for the tip!