Install Failed: A file corruption has occured

So, I’ve just subscribed to the Unreal Engine 4 and wanted to install it. (version 4.1)
So, all went well, the launcher works, the download started but somewhere in the install the launcher begins to ‘cry’ and gives me the error: “Install failed: A file corruption has occured”.

Now I’ve searched on google and this page and found some people who have the same issue. I tried the fixes they’ve supplied, such as reinstalling from scratch and create the file “$movedMarker”.
Neither did work… I’d really like to get to development.

I hope someone can help me,
Thanks in advance.

Some extra details:
Windows 7 x64
CPU: i7 2600k
GPU: GTX 770
AV: Microsoft Security Essentials

I have full permissions on the “Temp” folder, so this is not the issue

The UnrealEngineLauncher.log gives these errors:

[2014.05.23-11.08.30:471][ 0]LogStreaming:Warning: Failed to read file ‘…/…/…/Engine/Programs/NoRedist/UnrealEngineLauncher/Content/Common/Selector.png’ error.
[2014.05.23-11.08.30:471][ 0]LogSlateD3D: Could not find file for Slate resource: …/…/…/Engine/Programs/NoRedist/UnrealEngineLauncher/Content/Common/Selector.png
[2014.05.23-11.08.30:471][ 0]LogStreaming:Warning: Failed to read file ‘…/…/…/Engine/Programs/NoRedist/UnrealEngineLauncher/Content/Common/Selection.png’ error.

And a lot more .PNG errors.

I know it’s weekend, but, really? No answers?
We need to get going with the engine, we bought it and it doesn’t work. I think we can at least get some direct support?

Hi Serellyn,

I’m sorry you’re having this issue. I have asked one of our developers to look into it. Unfortunately, this being Memorial Day Weekend they will be out of the office until Tues. 5/27.

Thanks, TJ

Ah, I did not know that. Not living in the US so didn’t know it was holiday for you guys. I’ll be waiting for a reply.

Hi Serellyn,

Sorry you are having problems, and for the delay in getting help!

Would you be able to upload the whole logs folder for me? I would like to look for some clues as to your specific problem. Those PNG errors you pasted above, although look very similar to some other problems we have seen with PNG, are actually not really errors, they all appear near the top of your log file as part of loading and are simply a warning and symptom of us not distributing default UI content that we do not use :).

I’m guessing that you have already found the logs folder but here it is anyway for convinience


If you could simply zip up the folder itself and upload it here I will get on to investigating your issue asap!

Thanks for your patience

Thank you for your reply Swifty. The logs are, even zipped, too big to upload them here. So here’s a link to the zip file:
Since I’ve tried a lot, there are multiple log files in it.

I hope we can solve the issue soon.

Hi again Serellyn,

Sorry for the delay! I have been trying to reproduce your issue, and I think i now have figured it out.

Your installation is constantly failing on the exact same temporary file not being able to be created, on your system, that file is trying to go here:-

E:\Installed Applications\Unreal Engine 4\Unreal Engine\Launcher\PatchStaging\UE_4.1Production-Windows\Install\Engine\Plugins\Runtime\ExampleDeviceProfileSelector\Intermediate\Build\Win64\Dynamic\UE4Editor\Development\UE4Editor-ExampleDeviceProfileSelector.lib

It’s a long path - 260 characters. Windows support a path length up to 260 characters, so it would seem just 1 character too many. Harsh luck :(. Unfortunately, this means that your only fix is to uninstall unreal engine from the control panel and reinstall to a location that is not so long. It looks like you picked:-
E:\Installed Applications\Unreal Engine 4

Which ended up as
E:\Installed Applications\Unreal Engine 4\Unreal Engine

Perhaps you could reinstall to chose:
E:\Installed Applications

The installer will automatically create the “Unreal Engine” folder inside that.

I think this is the first time that this issue has come up! We will be sure to make adjustments to the install process to help users realise when this is a problem, and also reduce it.

If you backup your staging folder
E:\Installed Applications\Unreal Engine 4\Unreal Engine\Launcher\PatchStaging

And place it to the new location afterwards
E:\Installed Applications\Unreal Engine\Launcher\PatchStaging

You wont have to download the whole thing from the start, assuming you find some files in there.

I hope this helps, and sorry again for this inconvenience!

Hey Swifty,
Thanks for your help, this worked.
Have a good one!


Great news! And thanks for helping to bring this scenario to our attention :). All the best.

I’ve got this . Install Failed: A file corruption has occured. too when instaling 4.2.
here is the log folder. -