Install Engine not enabled

After installing Epic Games Launcher on Windows and clicking the Install Engine button, the + button next to ENGINE VERSIONS (‘Install a new version of the Unreal Engine’) is not enabled. There are no installed versions in the list.

I have previously installed the Unreal Engine succesfully on my MacBook Pro but am now trying to install it on my Surface Pro Windows.

I run the Epic Games Launcher as Administrator.

I have signed out of my Epic account on my MacBook but it doesn’t seem to make a difference.

Thanks in advance.

The problem was solved by removing the Unreal Engine from the Epic Games Launcher on my Mac.
After I did this - and restarted the Epic Games Launcher on my Windows - the ‘card’ with the version 4.26.2 was now available in the list of ENGINE VERSIONS that was previously empty.

This info may have been shown at some point, but I haven’t seen it. It would be helpful if info like this could be shown in the empty list as explanation and guideline.