InputAxis SwimUp Command not working in 4.9.1

Hey guys,

As always I apologize if my question is idiotic, but I can’t for the life of me get it to work in UE 4.9.

In version 4.8.x and all previous versions I successfully set up my Player Character Swimming animations in the following way (see screenshots):

  • I created a collision box tied to my character mesh covering the upper half of his model (so he could still walk through shallow water without triggering swim animations)

  • Afterwards I set up Two Overlap events in my Event Graph (see screenshot) that would trigger an SFX to enter and exit the water and communicate to the AnimationBP to start/end Swimming Animations whenever the box would collide with a physics water volume

  • Then I set up a SwimUp Command in the Project Setting Input Tab and in the Event Graph I placed a InputAxisSwimUp node connected to AddMovementInput with Z +1.0
    (just as written in this tutorial: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums)

So in short: Animation works, SFX works, Collision works, but SwimUp and Down does NOT work. And I don’t know why. I tried everything:

  • connecting a “character is swimming” node to tell the engine that he is now actually in water

  • I changed the physics volumes & Post process volumes, recreated them in multiple levels, still the same problem

  • I renamed all axis inputs, deleted and recreated them, recreated all nodes, nothing works.

  • I get no errors, neither in my animBP nor in my Exploration Character BP

  • I removed the entire collision box thing and replaced it with a basic swim script, no effect

This problem only occurs in 4.9, swimming in 4.8 was always fine and it worked smoothly, so when I downgraded it was fine again.

Any ideas? I couldn’t find anyone in the forums with a similar issue, has it already been flagged as an official bug?

Let me know,


Project Settings

Full Exploration Char BP Swim System

InputAxisSwimUp Node

Found the solution myself: The problem was the physics volume I had placed inside my world. I had it set on “only overlap with other physics volume”, it needs to be set up like this though:

Generate Overlap events YES


Coll. Enabled: No Physics Collision

Object Type: Physics Body





Everything else except projectile (block)

Then the SwimUp command works!