InputAxis LookUp - Mouse Y not working 4.13

I am new to UE4 and following a tutorial on Digital Tutors. At this one stage I setup the mouse inputs as shown in the video, but the pitch/ mouse Y would not work at all. I searched for a solution and found nothing more than others asking for help.

I decided I needed to just try things and see if I could get something to work. For some reason, adding the “Use Controller Rotation Pitch” Boolean in-between the (InputAxis LookUp) and the (Add Controller Pitch Input) and then checking the box, allowed the mouse to actually do something. However the mouse Y input was inverted. I went into the project settings and set the mouse Y to -1 and now the mouse works as I wanted.

Any idea why I had to find this workaround? Is there anything that looks incorrect other than what I had to do to get the mouse Y to work?

Hey Soup Pilot-

Can you provide additional information about the default settings of your project? When I open a 4.13 first or third person project the Look Up function is working for me. You mentioned having to set the scale for Mouse Y to -1 however this is the default value that I see when I create a new project. Are you using 4.13 from the launcher or a source version of the engine from GitHub? What is the template you are basing your project on?

Thanks for your reply Doug. I am following a tutorial that had me setup a new character. It was a first person view setup. I am using 4.13 from the launcher. I believe it is a blank template. Is there an easy way for me to share the files to be more helpful?

If you’re able to upload the project to google drive / dropbox, you can send me a PM on the forums with a download link. Also, can you try creating a new first person project and let me know what the default settings are for the MouseY in the Project Settings as well as if you have initial mouse control when playing in the editor?

Creating a new first person template with 4.13 does show the settings you described. The setup I did and had issues with must not have been a first person template. It must have been a blank template. When I went to the project setting page initially during the tutorial, there were not any axis mappings at all and we created them in the tutorial. I will pm you a link to the files. Thanks.

PM, sent on the forum. :slight_smile:

After reviewing the project, it appears that adding a new camera component to a character has the “Use Pawn Control Rotation” boolean set to false by default. This may be why the Y axis was not working initially for you. Setting up the MouseY input as you described and checking this checkbox for your camera component on a newly added camera should be all that is required for your LookUp to function as expected.

Cheers

Doug Wilson

You just saved me a whole lot of time… Thanks so much!!!