Input Not Detected (Simple Print String)

I was following the tutorials, and I got stuck on a quite simple one.

Outputting a number to the screen when you press E.

I created a new blank project, deleted everything from the scene. Then I created a blueprint where when you press “E” it set a variable to count + 1. (the One variable is defaulted to 1)

When this didn’t work, I suspected it was Print String not working as I expected it, so I added a print every tick. But that one worked as expected and displayed “0” every tick.

My Scene really is empty so I am not sure what is wrong.


Do I need 3d assets to capture the events ?

I also tried adding the “E” to the input action binding with no luck.

Any help would be appreciated


Ok so you should have this in your character blueprint. You can have it in a blueprint placed in the level as well but that’s a very messy way to handle input functions.

You probably need to enable input for your blueprint. On the event Begin Play do an Enable Input.

Thanks this led me right to the answer.

When adding the Enable Input in blueprint, i could not select a Player Controller since my scene was empty. But in the property of my instance (details / Input ) there is a dropdown “Auto Receive Input” set to disabled by default.

Once I set it to player 0 my inputs were working properly.

I’ll keep that in mind, but right now it’s purely exploration