Input Mode UI keeps showing standard mouse cursor

Hi Epic,

this might be a known issue, as it has been discussed previously: When I change the Input Mode to “Game and UI” or “UI only” and focus my menu widget, a standard mouse cursor appears. Unfortunately, this is not what I want, as I have built a menu which needs mouse input, but deliberately works without a cursor and looks just weird when it pops up in the center of the screen.

I have set the “Cursor” property to “None” in the PlayerController and the Widget, yet it still appears every time, even in standalone.

The user has provided a workaround in the Forums: UMG Compatibility - Code Changes: SceneViewport.cpp to 4.7 - Feedback & Requests - Epic Developer Community Forums

As I am no programmer, however, I can not use it. I would be very glad if there was a fix or a BP workaround to this problem. Any suggestions appreciated!


1 Like

Hello ,

If you would like for no mouse at all to show up you could apply a blank widget to the default mouse. This can be done in the project settings (Project settings > User Interface > Default mouse). Once there you can simply apply an invisible widget to the default mouse (This can also be edited at runtime if a mouse is needed). I hope that this information helps.

Make it a great day

1 Like

Cool, that worked :slight_smile: Thanks Rudy!