Input isn't working to open a door

Okay… I’m not sure why this doesn’t work, and it’s probably something really stupid that I’m overlooking.
I am trying to make a door that displays text as I walk up to it, and then I press E and it opens. However, if it is already open, I want to press E and have it close.
The only problem is… When I press E, it doesn’t do anything.
However, the reason I know that it’s an input problem, is because… well…
Let me show my blueprints.

It’s nothing extravagant. On begin play, it gets the initial rotation of the door. I have a collision box around the door. When I overlap that box with my pawn, it displays text. If the door is open it says to press e to close, and if it’s closed it says to press e to open. It also enables input so pressing E should activate it.

The second screenshot shows what happens on the end overlap. It basically makes the text nonexistant and then disables the input so I can’t affect the door anymore.

Then there is the section about pressing E. It checks to see if my pawn is overlapping the collision box around the door. If I am it checks to see if the door is open. If it is not, then it should go through the animation to open it.

Now… the reason I know it’s an input problem. I can take the “on component begin overlap” node, and use it in place of the E node, and it will auto open as I get close, and auto close when I go near it again. For some reason, Pressing E doesn’t activate it though and I have no idea why.

When I Enable Input on Begin Play, it makes it so the door can be opened no matter where I’m standing in the world. The reason I have it set to enable input on begin overlap, is so I have to be in range of the door to open it.

Enable Input on Begin Play. Now you have conflict - when door is closed - you can’t open it.

You should do another check. Just Press E is enable when begin overlap, disable when end overlap but input should be enable from Begin Play. I have now editor closed, but it should help, I can check it later in ue.

okay I got it. I moved my enable input node to the EventBeginPlay node, and then added a “Is Overlapping Actor” node when E is pressed. So it looks like this now:

And now it works. Thanks for the Help Vaheva!

It’s why I said - you should do another check what will be enable E action only when player is inside trigger.

Good work :wink: