Download

Input from button pressed isn't working

I think this will have an easy solution that I’m missing but my mind has gone blank over this.

I have a little set up where you walk up to some objects and when you interact with them, your camera switches to one set up above these objects to act as an in-engine menu. From here, you can toggle between each object selection and pick one. My problem is, I want to move/switch between each object in the “menu” with A and D for left and right.

“D pressed” isn’t firing though (Input is enabled), which I assume has something to do with the fact that ‘D’ is also the input for first-person character movement in the project. What am I missing that allows my D pressed in the blueprint to ignore the character movement and fire off? Thanks!

You should probably check fr something called consume input. I don’t remember it it’s in the input otself or the pawn, but that may be what you’re looking for. Basically, if An input is consumed, it stops there and won’t fire any event in other entities.

If you could show me the blueprint in question, I might be able to help you. It is difficult to backtrack the problem without seeing the blueprint :).

I have ‘Consume Input’ checked on the ‘D Pressed’ input node within the blueprint. Do you mean that or is there a similar checkbox elsewhere?

Sorry about that, here’s a quick screengrab. I threw a log in straight after the input node but it doesn’t fire at all :confused:

173a97a5e55dd09f5fd1a601f189f9909782bfcb.png

Did you try to remove the “branch” node and plug the “pressed” node directly into the “set” node? That may indicate a problem with the boolean. Is the d key working in your other programs? Just to make sure, your keyboard isn’t defective.

AHA!

I just went into my Controller blueprint, found the ‘InputAxis Movement’ nodes and unticked the ‘Consume Input’ on those and it works now! Thank you very much for pointing me in the right direction!

715f67c935001358320fd56b98a8befcdd92837c.png

Thank you both for helping :slight_smile:

Glad to hear it :). Have fun with your project.

I too had this problem. I couldn’t find the Controller blueprint but found another way to fix this.

My keyboard input code is in the PlayerStart_Blueprint. So I selected the PlayerStart and in its details, under Input, I changed Auto Recieve Input from Disabled to Player 0

PlayerStart.png