Download

Input for Pick up Please Help

Hi,
I have created a blueprint to pick up items on BeginOverlap which works fine. However, I would like for my character to pick up the item when the P button is pressed. I have tried replacing the OnBeginOverLap with the P key Button Pressed but I am not able to get it to work. Can you please instruct me how to get my character to pick up items and add to the inventory only when the player pressed the P key? I have enclosed screen shots of my PickUpBrick Blueprint and also of my character blueprint. Thank you for your help.

  1. add a capsule to the items which enables a bool variable
  2. now add the “P input” - connect it with a branch - add the bool variable to the branch
  3. now it should work :slight_smile:

Hey thanks for your help I followed the steps you suggested. The item still will not pick up if the P key is pressed. I added the changes to the item to be picked up blueprint. I attached a screenshot. Will you please tell me what I did wrong?8151d420bdaea0f32f6e1d123ca7218efeebcf32.png

-you will have to connect something to the condition link from your branch (there you should add the variable from the capsule overlap event) :slight_smile:
-in an actor bp you also have to enable the input -> add an event begin play node - connect it with a “enable input node” - connect a “get player controller” with the “enable input node”

If possible could you please send a screen shot? That would help me.

I am a student. I am learning. I have followed your instructions but for some reason my item is still not able to be picked up by pressing the Pkey. I have enclosed another screen shot. Can you please send a screenshot of what I should do so I can have a visual? I have tried various ways and am not getting the outcome I need. Thank you for all of your helpPEventAdded2.png

When I’m back home I will send you one :slight_smile:

Ok! Thank you! I really appreciate it very much.

That’s how you do it in your item actor blueprint:

db62a4e1e634bc7106ddacd897d2d1133f0d0a8f.jpeg

9862223b1554b424e6475cf2d044cdaf065aeed1.jpeg

I really appreciate you help. I followed your instructions carefully and now it does not recognize the P button at all. Before, when the P button was pressed the character would perform the pick up animation but now the character does not and the item does not pick up. I have enclosed screenshots. Can you tell me what I am doing wrong please.e7385dee3755ac1c6729f5a8717913a2cfc6d71b.png648210275ac823fca47063619f335e40d2d8589e.png0b6f99fede177e1a49422c4fc97b597057acff2e.png

Thanks…

Worked Perfect.