Input Events are not being called?

I can’t seem to get input to be called even when I have the correct options. This is almost an empty project so there’s nothing else consuming the input because I simply have this ONE pawn that handles all the code it needs to roll the “dice”.

Here is the blueprint, and here:
you can see that input is enabled. All I want is for the dice to reroll itself and call those functions when the mouse is clicked or another key but I can’t get ANY input to work at all. You can also see that my project is nearly empty:

I’ve been reading a lot of other forum posts and they have the same problem but no one has an answer other than “Enable input” and other things that have not helped at all. I have no player controller and just want the pawn to handle all input and code. And yes, I have clicked on the screen when I started to simulate…

Hey there @Riondale! Welcome to the community! So if you have no player controller, UE actually assigns kind of a basic one. However you still require the pawn itself to be possessed or to call it from wherever your controller handles logic from.

Is the dice a pawn you possess, or as the player are you the camera right now?

Is your pawn set as the default pawn in the GameMode inside the WorldSettings? If it is not, did you try to enable AutoPossesPlayer (second screenshot in the details panel on the right)?

Example with GameMode: (816.4 KB)

I don’t have the dice possessed and I’m not sure how that all works. I’m very new and I just have the default camera doing all the controlling

in the example I provided you can go to Content / Dice and double click DiceMap:
When the map is loaded you can go to WorldSettings on the right side:
There is the BP_GameMode selected as GameMode Override. This is a BP I created. It just was created and then selected, no values changed. When you select it here you get to choose the Default classes. It usually looks like this:

So no you could select your DicePawn (here BP_DicePawn) as your DefaultPawnClass.
This is one way to do this. If you do not want to use a GameMode, you can use the default settings for your level (no extra GaemMode), put your pawn just inside the level like this:

You can do this via Drag&Drop from the Contentbrowser. Then you can select it inside your level and go to the Details tab on the right side:

Here you can choose AutoPossessPlayer. When you set this to Player0 you will be able to move the pawn.

Thank you, I’ve got it working. The only problem now is that when I possess the pawn I have a camera set up on it but I don’t want it to move. I just need it to stay in one place. How can I achieve this effect?

Do you have the Camera on a SpringArm? Like this:
Then you can deselect the Inherit options under CameraSettings in the blueprint. Select the SpringArm. Then do this on the right side in the details panel:

1 Like

You are a godsend my friend