Input Action Mappings not working in Shipped Build

Hi,

After creating several new action mappings in a project based on the VR template, the new bindings work in the editor & development build, but not the shipping build. It is only an issue with the newly created bindings.

To make this more confusing, I was unable to replicate the issue in a new project.

No idea what’s going on here, any help appreciated, thanks.

Edit: Since I can’t replicate it, perhaps a certain file is corrupted? Any suggestions?

I’m having the same issue. Could you find any solution?

I have not, I think it’s beyond my knowledge… Please post here if you do find something though.

As a heads up, you might be using the save bindings function. You should not be using that, not even Epic recommends using it as your input remapping system ingame because it is permanent. They recommend using a save file: From Epic themselves for what they do on Fortnite(link)

I just checked and my input events actually work in level blueprint, so I have some problems with character possessing or something like that ( events don’t fire in character blueprint ).

This only happens in shipping, strange mismatch between shipping and in-editor behavior.

Also running into a bizarre similar issue. It appears to work fine in DebugGame. The shipping build also appears to work fine if I copy the build to another machine (tested with a keyboard key)!

Okay, so I had a very similar issue—except Shipping worked on other machines. Turns out my local config was haunted.

  • Open %APPDATA%, go up and into Local/YourProjectName/Saved/Config/WindowsNoEditor
  • Check if the Input.ini file has an obsolete version of your actions. If it does, that’s probably the source of your woes.

I just deleted the whole Local/YourProjectName folder but you can probably get away with deleting just the Input.ini.

Couldn’t say why this happened; I was using 4.22.3, SteamVRInput, and Perforce.

I was really hoping this would fix it, but unfortunately not.

Interestingly though, I was also having the issue after installing SteamVRInput. However, I still have the issue with these action mappings after uninstalling the plugin. I also tried deleting the config folder in the editor project’s folder with no luck.

Anyone: Is it possible to have different settings for something in a Development vs. Shipping build? If so where would these settings live?