Download

Inherited component details not showing in blueprint?

Hello, for some reason my capsule collider won’t show details on any blueprints.

380bf82ce409d6179cd4e77ac273444ac597ca61.png

Here’s the .h code

2175ee75270df8c9e515bb74915a8895f8ba5dc3.png

And the implementation

032763f9644142e56e2136648accb5ebcd568e1e.png

I went back and copied the .h and .cpp from the built-in Character class that works fine, so… why isn’t mine displaying in any of the blueprints? (All the other components display just fine)

Thanks

Bump, someone has to know why the details panel is simply missing.

This started happening to me a while back and I never figured out what fixed it. Try getting rid of ‘BlueprintReadOnly’ and see if that does it.

Did you check the “Show All Advanced Details” ?
fc96ef730f35bb59d2ccc582862f731c67ddc2da.png

Yup. I’ve also tried a number of things in the code including EditAnywhere, etc.
I simply can’t get the capsule collider to display, which is a problem because now I really need to modify it’s collision settings…

Did you ever resolve this? I have exactly the same issue: https://answers.unrealengine.com/questions/560519/uwidgetcomponent-not-showing-details-in-blueprint.html

Try recreating the Blueprint. Sometimes they don’t update. They also have a tendency to hold on to old information as well…

Any new info what is causing this? I have the same problem. Recreating the blueprint didn’t help.

I ran into a similar issue.

I believe it reared its head after moving about 20 very simple materials into a more appropriately named folder. (I believe I had some undocked windows open during the move.) The materials were being used by various skeletal and static meshes in a handful of blueprint classes (namely character, and pawn (one parent, 1 child)).

After having done that, the only things I can edit on any given component are events (On X button pressed, etc.). Nothing else can be selected/changed unless the static/skeletal mesh is already a component in a class AND is selected in the viewport. Recreating the blueprint class from scratch doesn’t fix it.

Edit: Window > Layout Reset fixed it for me.

I found a way to fix this, I rebased the actor to the lowest level I could, Actor or Pawn, then rebased it again to my c++, fixed it all and I didn’t have to rewrite anything in c++ or in the BP

I believe it a bug: If you add the component to the parent class AFTER you created the child blueprint then the new component’s details panel won’t show up. The only way I know to fix it is re-parenting but that means you will lose all the existing datas you changed in the child class.

Your solution worked for me, thx.

I found that this often occurs when not using the proper actor constructor and not using Object Initializer to create components. If the components were added/changed after the fact, then refreshing the blueprint brings them back. Looks like some UPROPERTY meta gets baked into the BP somehow.



AActor(const FObjectInitializer& OI);


I can confirm that this issue persists in 4.20.

Still having this issue 4.20.3

Worked for me aswell. If one inherited Component doesn’t show any Details in the BP-Editor, reparenting to Actor using “Class Settings” -> Parent Class and reparenting back to the original file works fine. Even though the parent c++ file can access the Component, the BP file can’t even though it is not “directly” trying to access it. (Engine Version 4.20.3)

Also a problem here. I have a parent class with a billboard component in it, and the construction script changes the billboard sprite and prints it to log. I then make various child classes from that parent. On some children it works and on others it doesn’t - the log always says the instance’s component has the correct sprite but the placed instance’s component doesn’t reflect the change.

In the end I just had to give the children their own billboard component always. I can still do the work in the parent, but I have to return the billboard via an interface function that I override on each child, which is a bit of a pain in the ass but ensures it always works.

Eh, started happening to me in 4.21.1. Not every class, but some.

Hi! I´ve been facing this problem in different engine versions for the last 2-ish years, so I decided to write the ultimate bug report at UDN. Hopefully this will be the time where we can find a good solution.
https://udn.unrealengine.com/questio…-is-empty.html

If for (like for me) re-parenting is not an option (it will break you BP hierarchy, it will not compile because the logic related to the components your base class is adding from c++, you will have to re-set everything again, even transforms and rotations…) there’s one solution that worked for me twice already: rename the c++ variable that points to your component in the owner actor. My best guess is that, by renaming it, the unreal build tool actually recompiles and updates all the info in the owner actor blueprint. We had this problem with 2 components after I renamed the class of said components. The details panel was empty. Did the renaming trick in the variable and magic! all was good. Then I was able to rename the variable back to its original name.