Download

Ingame it looks not like in Editor...

What´s the problem?

I changed a little bit in the shadow options, because my shadows was ingame totally black, but then after upload, ingame all things was shiny, but in editor it looked wonderful.
Now I tried about 20 little changes and I don´t want do it anymore, because every cook and upload needs 1-2 hours (+ download)…

What options I have, to see the things in the Editor, like ingame?

And what can I do for the brighter shadows?
Cubemap isn´t good…

try in game r.bloomquality 0 for the shininess…

sorry, but can you say me what you mean?
I´m not a coder…

This is my first project in UE4, I want only build a nice Map, I don´t thought before I started, it is this complicated…

I have the same problem, I copied everything related to daylight system from theisland but I still get pure black shadows.

Do you have copied the Level-Bluebrint, too?
In my map I saw no rain, but that´s not a problem for me (for now)

I hope anyone has settings for nice shadows, the Cubemaps make everything shiny…

If I try to copy the level blueprint my editor crashes :confused:

you must copy it in a few small parts^^
after you are finished with this, you must put all links on the right location and view the error log after recompile,
but it´s not easy…

Sorry for being offtopic in your thread but could you tell me how to link inside the level blueprint?

edit:

Nevermind I figured it out, going to try and link everything now.

Bumping this topic because I ran into the same problem as OP.

I finally got my lighting set up correctly and shadows were nice in the editor window but as soon as I simulated the shadows were pure black, same thing in game after cooking and uploading. In editor shadows were nice and in game (in editor or actual game) shadows were black.

I selected my skylight and unticked “Bake and Stream” then simulated the game. I went out of the simulation and reticked “Bake and Stream” and simulated again. The shadows in the simulation were nice and soft.

np, happy linking^^

I have now found out, how the shadows work…
Get in your DirectionlLight Details and search for “Shadow Filter Sharpen”
shadow.jpg
Change the value to a negative (not too much, -1 looks crappy on my map)
“Shadow Bias” should be at 0.5 (try what happens on 0)

After this part, there want be appear a circling shadow:
c69aee95d8c7aaf3479aa528936b8b35de80b53b.jpeg
To delete this or get it further away, go down to Cascaded Shadow Maps
shadow.jpg
Change the Value of Dynamic Shadow Distance, on 0 the circling shadow want be deleted, but your other shadows are not animated, if you set it up, the circling shadow goes further away, but if you turn your cam up, the ground gets darker…

Maybe, anyone find out, how we can delete this circling shadow and have the animated shadows?

I figured out how you can make a map with the official settings:

You only need to copy the map “TheSmallIsland” (Folder: Game/Maps/SmallIslandSubMaps) and when it´s done (can need a few minutes if your RAM is not big enough, like mine, hehe), put all things in a folder and rename it to “original_files_dont_delete”

ATTENTION
You can delete some assets in this map, but I don´t know if you need them later:
Dirt_Plane and WaterPlane,
maybe the WaterPostProcess_2, if you want make a new one, because it is referenced in the LevelBlueprint

I got this way now for my new testmap and I can play with the Submaps-Option activated, in the active viewport without falling through an complete empty world^^
More test-results coming later…
I had yet the problem, if I make foliage for a submap, all things get out of my map and flying over ocean, out of the LevelBounds, I hope it want work now (my maps have no submaps because this problem)

Edit: The Foliage on a SubMap works now for me^^