Infinite Loop Detected in Strange Areas

Hello. Earlier today I was working on a project, and I made something like this.

Later, I realized this was an infinite loop and sure enough, got the error.
However, upon deleting all of the code, I still get an infinite loop error, and now I can’t start my project at all.
The infinite loop error points at many random areas in the code.

The first time, it brought up some function which I didn’t even put inside that blueprint called the Flush Net Domain.
Then, it worked, but after trying again (without editing anything), it brought an UnLooping Set Timer By Event block in the gamemode.
Then, after a few tries (again, without editing anything), it pointed at the Tick block inside another blueprint.

My infinite loop breaker is already at 2 billion.

This has been really awful. I’m not sure if this is a bug, or if I’m doing something wrong.

Thanks in advance for the help.

Cut the blueprint that has the infinite loop from your project’s content folder, and move it outside, then try loading your project and move the asset back in, and remove the infinite loop from the BP.

After reinstalling and updating the engine, the problem fixed itself.

The problem fixed itself. Thanks for the assistance though :slight_smile: