Download

Industrial cooking pot kibble not cooking?

Hello,

I create an copy of Industrial cooking pot (a simple copy) and kibble is not cooking?
What have I forgotten to check?

Please help…

Thanks.

Holgi

Try making a child

Maybe it’s just me, but those cooking inventories don’t have half of the cookables in their default inventory. Not even fish meats! I’ve no clue how it works in game, but for the dev kit I had to manually add them to the inventory. This is why my stack mod no longer touches the cooking pot or industrial cooker.

My solution looks like this:

Create an child of:
PrimalInventoryBP_CookingPot_Industrial

Create an copy of:
IndustrialCookingPot
EngramEntry_IndustrialCookingPot
PrimalItemStructure_IndustrialCookingPot

Now open the IndustrialCookingPot BP and click of “Components”
Change the Class PrimalInventoryBP_CookingPot_Industrial to PrimalInventoryBP_CookingPot_Industrial_Child

Open the PrimalGameData_BP_GenericMod file in your mod directory and Remap Items
PrimalInventoryBP_CookingPot_Industrial -> PrimalInventoryBP_CookingPot_Industrial_Child

My modded Industrial Cooking Pot cooks kibble now :slight_smile:
1e6322c46471fe93041a952a9a26b129aba88515.jpeg

4b0a32ffdf362603bbaa2bf793332086bbe67a35.jpeg

HolgiStar, I have following your instruction to the letter but I still cannot get my Cooker to cook kibble… I have also tried adding the test kibble primal item consumable to the default list still with no results… I am sure I am just missing something really stupid simple but I cannot for the life of me find it. I have used the Diff selected tool and checked my inventory blueprints AND the main blueprint, still no luck. This is Dev kit 268.3
(EDIT) I did explicitly add the Primal Item Consumables to the Default Inventory list and lo aand behold, it would NOT work in the devkit Test map but it DID work in Game… Very very strange…