Download

Indoor/Outdoor Archviz Project

Hi guys,

Here is my latest project, made with 3ds Max and UE4. For some reason I thought it would be a good idea to include foliage in the scene, as opposed to what I have done before with just indoors. The foliage caused me some real troubles and I’m going to have have to figure out a better way to do it if I do again. The main issue that I ran into is that you can’t build the lighting AFTER adding foliage to the level as it fails and takes forever, and there is no way to just build the lighting on the architecture and furniture (hence my thread about the limits of UE4’s lighting system!) Anyways, the inside of the building is what counts, and I think I got the lighting down pretty well. Settings are below in case you’re interested.

Static Lighting Level Scale: 0.1
Num Indirect Lighting Bounces: 100
Indirect Lighting Quality: 10
Indirect Lighting Smoothness 1

And in the BaseLightmass.ini:

NumHemisphereSamplesScale=100

I was also a bit disappointed with the quality of the lightmaps on some of the models from Turbosquid. They don’t really seem to play nice with UE4, specifically on that red chair. I guess this is what you get for being lazy and not making your own furniture models.

Another frustration of mine is the reflection system in UE. I can’t find a way to replicate glass as realistically as I would like. If anyone has, help me out here!

Let me know what you think :slight_smile:

Looks good! Reflections on glass and mirror are a big problem, you can try a reflection capture cube (I think that’s the name).

Yeah, I have one covering the whole scene and a few small reflection captures inside. It looks pretty bad for some reason though. Do you know of any way to change the reflection capture quality? (I’ve never really worked with fully reflective materials before)

Umm, I think I have the name wrong, here try this:

  1. Add a “Scene Capture Cube” in your scene (it will look like a camera in the viewport).

  2. Create a new “Cube Render Target” in your content browser (it’s under "Materials & Textures).

  3. Add the Cube Render Target you’ve just created in the “Texture Target” on Scene Capture Cube details:

  4. Now you can add the “Cube Render Target” as a node in your material.
    Combine it with a color and plug it in the Base Color channel of the material to fake the reflection.
    Don’t forget the “Reflection Vector” node to adjust the coordinates properly. Example:

Note that the location of your Scene Capture Cube is very important as it will determine the center of your cubemap.
You can think of it as a replacement for the default Reflection Capture, but with the possibility of increasing the resolution
(under Cube Render Target details) and with real time capture (it will be much more expensive because of that).
You can disable the real time capture under the Scene Capture Cube details panel (disabling “Capture Every Frame”).

Ok, so the first part is fine, and I have tried this technique before. The issue is in the 4th step, getting the “Cube Render Target” into the material. That node does not seem to exist for me, and the closest I can think of is the “MaterialExpressionTextureSampleParameterCube_0” node. I connected this to my base color and assigned the cube map I made earlier for the reflections as the texture, as it should be.

The entire function, with the color and cube render target added to it (with the arrow), connected to the Base Color, all highlighted

This is the part I’m not so sure about, as the node might be wrong. I referenced the capture that I made earlier and used it as the “Texture Base”, as seen on the bottom left. I added a random color to it, and connected, but with no result. Same thing happens if I don’t add any color.

I don’t know if this is right because your example images didn’t come through, but I have a feeling its quite wrong… Maybe you could point me in the right direction :slight_smile:

I used some free models from turbosquid and other 3d sites and afaik they all don’t have light maps, usually I must create the light maps from scratch. Good for learning about UE4 light maps actually, since you can separate/arrange the light maps so dark/shadow maps won’t bleed over bright/light maps.

I found the technique here on the forum, those instructions are not mine. I looked at one of my scenes where I tried to implement the technique, not sure if it’s working as it’s a simple interior scene. Anyhow, here is a screen grab from the material - I hope it solves your issue. If not there are others here that know more about this technique, maybe they’ll chime in.

cb0a87b2060f8853f75ab346b2be27648a0a5d35.jpeg

Hey that helps a bunch, thanks!

Yeah, but these said they came with light maps, but of course you have to make your own for UE4. The models themselves look quite nice though