Download

Indirect Lighting Intensity value under skylight not working in UE4.26

Hi guys, 3 days ago I installed UE 4.26 for the first time on my system and recreated an old test project that I had made in UE 4.23

It was all fine in 4.23 with no problems
Now I have worked on 4.22-4.25 but never in UE 4.26 so don’t know what has changed in the skylight but increasing the “Indirect Lighting Intensity” does nothing to the GI.
I can increase the indirect lighting intensity in the PP but I don’t want to.

Please check the attached images with details mentioned.




Below are the settings that I am using for the bake and using a RTX 3070 Ti for the bake.

Have you tried to recapture the scene? There is a button in the skylight details panel. Or maybe they capped the value at 1.0 in 4.26?

I know this doesn’t answer your question. But the original purpose of the skylight in unreal was to flood the scene with a low level of light. It wouldn’t even cast shadows. It has become a bit more than that over time. But personally I never use it to light up the scene in unreal and it was always something lighting artists would use as a last resort.

With ray tracing enabled I don’t use a skylight at all. I find it is messing up the reflections. (You also won’t need it with Lumen). Maybe try using rectangle lights covering the window opening with an intensity of 0.5 cd in raytracing instead. I think it works great.

Probably better to use exposure control in the post process volume instead of indirect lighting intensity. The unreal skylight isn’t what it is in vray. But that might also just be my personal preference.

1 Like

Thanks! I had the same issue in 4.26 and 4.27. It’d work with specified cubemap but nothing else. Now I know why!

Thanks. I am using an HDRI in the skylight, so I don’t think that recapturing would be of any help.
And I don’t wanna use rectangle lights on the windows either.

But do let me know how do you light your scene when raytracing is enabled as I only recently got a RTX card and don’t know how to make the best out of it.

If all else fails, I would jump back to Exposure Control under Postprocessing

Why isn’t it working for me then? I am also using an HDRI in UE4.26

Here is a screenshot of a little pet project I am working on right now.

There are static rectangle lights covering the large windows with intensity set to 0.5 cd and a attenuation of 2000. They simulate the light that would come in from the outside sky. I have no skylight. The only other light at ground level is the warm kitchen light strip.

I have a stationary sunlight with intensity of 10 lux. I always try to get direct sunlight into the scene. I increased the bounces to 5 in the lightmass world properties. At this stage everything else is default. Light has been built in Production Quality (I think) with standard cpu lightmass. It helps when the walls are not pure white. Makes unwanted noise a bit less obvious.

The post process has ray tracing enabled for AO, translucency and reflections. I increased the bounces a bit. The exposure is set to 1.0. I also put the standard daylight LUT in and reduced the saturation to 0.95.

That’s it. Nothing special really.

1 Like

You’re using GPU lightmass to bake which doesn’t support the indirect light intensity setting (yet).

Do you have specified cubemap turned on? Maybe take a screenshot of your SkyLight settings?

Looks great dear. But I didn’t wanna use the lights at the windows. In versions prior to 4.26, everything worked as I liked and I became accustomed to it. Anyways, seems like the indirect lighting intensity isn’t working for some reason now so I had to add fill lights.

Thanks for your input.

Oh. Thanks dear. Just checked. I hope they have added it in 4.27. Will check it there.

Thanks dear but it’s a limitation of the built in GPULightmass in 4.26 like Arkiras said.