Download

Incompatible to ProceduralMeshComponent 4.8.0

hey guys,

i updated from 4.7.6 to 4.8.0 and now my procedural mesh generation doesn’t work anymore :frowning:

at first i had to delete the library ( https://wiki.unrealengine.com/Procedural_Mesh_Generation ) that i worked with, because it’s now provided as plugins. so i included the plugin “ProceduralMeshComponent”.

so far, so nice, BUT: the method “SetProceduralMeshTriangles” doesn’t exist anymore and i can’t find a workaround :-/ maybe i have to work with the new method “CreateMeshSection”, but google results for that are only one…

anybody any experience with the new plugin? maybe an example or tutorial?

I don’t mean to be derisive but there is a massive thread about this just above yours: https://forums.unrealengine.com/showthread.php?1552-Generate-Procedural-Mesh

If you have a look in the last couple pages you can see that this is now included as part of the engine. Since the name conflicts it means that the old one won’t work unless you rename it. You can also just disable the new plugin if you want to stick with the old implementation.

thanks for your quick answer.

and yes, i know that i could rename my existing class or disable the new plugin, but that is not my aspiration.
i want to work with the new plugin and can’t find any information about usage :-/
i know the named thread, but there was no answer for that since weeks, so i tried to ask at a more attracted position :wink:

They demoed it in one of the recent livestreams. I think it was the first 4.8 preview one, that might have some of the info you’re looking for. As far as I know no ones written any sort of tutorial for it yet.

I’d check out the header file for it in the plugin and look at the example Kismet library included with it. By memory there’s a function to make a cube so that should put you on the right track.