In game very low resolution !! Why?

Hello !

(Version 4.8.3)

I come back with a strange problem in editor and in game…
I’m working on a VR project, a simple walkaround a plane in a warehouse.
Everything is fine until this morning when I came back on the project, open the editor, hit play and boom! The resolution is now very, very, very low!!

I’ve got the same problem with a packaged .exe, the resolution is very low.
I’ve checked the engine scalability settings but everything is High…

I had the same issue two days ago with the same project… Only way to solve it, was to create a new project… -_-

Do you have any idea about this? what causes this problem? Is it a bug?

Hello JayC3D,

From what you have described you launch a project in VR mode after saving it for the night and opening it the next day. Whenever you do that you see a lower quality upon launching.

Currently ScreenPercentage and MobileContnetScaleFactor don’t do anything on GearVR at the moment. We always render 1024x1024 per eye.

From what you describe it sounds as if what the settings are not persisting after closing the editor. A way to fix this is to manually set up the quality settings in any of your .ini files.

Steps to reproduce

1.) Go to your [ProjectDir]/Config/DefaultEngine.ini
2.) Open it
3.) Enter [GearVR.Settings] GPULevel=3 CpuLevel=1
4.) Limit the number of Dynamic lights in your scene.
5.) I would recommend not using any post processing that you have in the scene if you have any.

If you are still having this issue after you try the above mentioned steps, then please link me your .uproject, content, and config files for your project. This way I will attempt to reproduce this issue in a controlled test on my end using the exact setting and files that you are.

Let me know what you find out.

Thank you,

Hello JayC3D, From what it looks like is that you have not rebuilt lighting yet to rebuild lighting.
Go to the build button then click the arrow next to it set the build lighting Resolution set it to Production if you want high quality build then click build lighting only.

Hope this helped!

Hi !

Thanks for your reply!

But I don’t understand why you’re talking about Gear VR, I forgot to mention that we’re using rift DK2…
May be this info will change your theory?

Hi Matt !

That’s another problem, I don’t understand why I’ve got the “LIGHTING NEEDS TO BE REBUILT” message…
Even after rebuild the whole scene with Lighting Quality set to Production.

We’ll I have no idea about the rebuilding thing since my rebuild stuff is broken. I will investigate this problem of yours!

Update !

I find something interesting, I couldn’t improve resolution in editor but I noticed that when I launch the game.
The resolution is still very low but when I hit Alt+enter to go fullscreen and play the game in the Oculus Rift, the resolution is correct…

I tried to tweak some values in different config files but no results…
I also try to reproduce the problem with another project… No success too…

Ok, I solved my problem… In the post process volume / Misc / Screen Percentage was set to 0…
Bring it back to 100 solved the issue…

Similar issue happening here. Though I could not remember I have ever touch that option. Thank you.