In game close up Nanite objects are low quality

I’ve imported some Nanite meshes (large cliffs) from Quixel, when in game mode (or even in viewport), if I get close to these meshes, the texture appears really low quality.
Is there a setting to change this?

Have you checked the settings for LODs? LODs stands for Level Of Detail, which changes the mesh texture and resolution based on distance from the camera.

Looks like its going back to the fallback mesh. A few things to check:

  • Are you using forward renderer? thats unsupported.
  • Are you using Direct 12 and SM6? those are required project settings (Dx12 should be the default RHI as well)
  • I think you need virtual textures enabled as well?