In App Purchase IOS not working [Solved]

So now after several weeks of trying and different approaches I need help now.
My App is released on Google PlayStore and everything works fine there. The problem is with IOS. The “in-app purchase” just does not work. First, I want to describe what I have already done. Maybe you recognize a mistake I made. But since it works on Android, I think that it is a setting error of AppStore Connect.

I build my Game via Remote Packaging from Windows.

I have uploaded a new Version of the Game and created the None-Consumable-In-App-Purchase and selected it before i submitted it for review.
The In-App-Purchase is approved with the latest Version of the Game on the AppStore Connect. (I am wondering if it has something to do with “Content-Hosting”?. ATM it is set as NOT-Content-Hosting.

I have the following under … Config / IOS / IOSEngine.ini:

[Online Subsystem]
Default Platform Service = IOS

bSupportsInAppPurchasing = true
bUseStoreV2 = false

Default Provider Name = IOSAdvertising

It is a fully Blueprint-Project and since its working on Android, the Blueprint should not be the problem.
I setted a random product Identifier id-String in Blueprint and noted it later for AppStore Connect IAP-Product ID.

Still after downloading it from the AppStore…the “Read In-App-Purchase” does not work (price not readable-unset) neither the Make-IAP-Function for buying the full-Version.
I am completely exhausted after the several Uploads of the game and the Xth In-App-Purchase I created…^^
Hopefully somebody has an answer for me or can tell me some solutions I can try.

I have also waited at least 72 hours, because some forums say that Apple needs time to integrate this into their system.
EngineVersion 4.22.3


Ok, so I feel a little stupid … After watching the match3 example video again and paying attention to every single word, the sentence fell: "We can not show you the backend documentation, but look at their sites … ". So I did this. And indeed, I completely forgot to fill out the contract that allowed me to take purchases.
But I must confess that Apple is extremely tricky here (No information at all on the Store-Page).
So somebody should have problems with that as well:
Under AppStore Connect → Agreements, tax, and banking overview → make sure your Paid-Agreement is set to active. Otherwise, fill in all the data.


Glad you got it sorted. There are so many little hurdles like this! Thanks for posting your solution for others! Perhaps you could you edit your original post title with [Solved].

Thank you so much for updating with solution. I really appreciate your efforts