Importing Vectors into Data Tables

Hi All,

I’m struggling to import vector and transform data types from csv into data tables. I can’ seem to work out how the entry should be parsed. When an empty table is imported is comes up as:

AVectorType: (X=0.000000,Y=0.000000,Z=0.000000)

Inputting (X=1.000000,Y=1.000000,Z=1.000000) gives an error, as does using other characters like ; or \ to separate values…

Please help!

If you struggle to import data just check how its formatted when you open the strut.

I was able to import a vector 2d by simply using:

(x=1,y=1)

This is the same format showed in the strut. I also tested with a standard 3 vector and it worked for me using:

(x=1,y=1,z=1)

Hope this helps.

I’ve re-tried both of these with no joy: neither Vector2D or 3D vectors work:
Lines read:

Name,A
1,(X=1,Y=3)

in the text file, and importing gives a “malformed string” error message :frowning:

The answer is double quotes…

Name,A
1,"(X=1,Y=3)"

This works…

Just BTW … If you are saving .xls to .csv from OpenOffice.org CALC, the option to have “” added as a text delimiter is given on save in a pop up dialog so the cell can just be (X=0.1, Y=0.2, Z=0.3)