Download

Importing Tiled Landscapes Using Non Weight Blended Layers

Does anyone know if its possible to import TILED landscapes when using non weight blended layers???

I had this problem in the past and I could never find a solution. When you import tiled landscapes, the LayerInfo’s it created are ALWAYS weight blended, and as far as I can see, there is no option to choose non weight blended when importing.

I know I can import a tiled landscape, close the editor, then copy the non weight blended layer info’s over the weight blended ones, but this doesn’t work.

This is what I get when I try to import this way.

&stc=1

I don’t know if it has anything to do with it. But when im trying to import my landscape, the layers aren’t in the correct order.

EF3BkS5.png&stc=1

I’m only using non weight blended layers so I can remove foliage with its own layer.

My material is setup so that the base layer is a combination of grass and cliffs, blended together based on slope

&stc=1

Subsequent layers are blended in like this…

LNLggJy.png&stc=1

And then the top most layer which is snow. Is blended in like this…

&stc=1

The idea is, this gives me control over the procedural foliage. Pretty much the only reason im using non weight blended layers. But I just cannot get it to work with Tiled Landscapes.

Anyone else experienced this or know a way around it?

Thanks a lot in advance!

With L3DT Pro I pre-flip Y inside L3DT for both HeightField map and Alpha Maps. Then I export the tiles to UE4 and disable the Flip-Y when importing in the UE4 import window.

I’m sorry. But that has nothing to do with my problem. Did you read the post at all?

The landscape height has imported just fine. Its a problem with using non-weight blended layers in my landscape material.

I found this to be an issue without resolution, myself.
I would import tiled, and, everything would be fine for a while and then i would get this exact issue. No reason, no changes, just, random. If you migrate to a “new” project, the landscape and all that, it will resolve (sometimes) but only for a short time. I have no idea what causes this at all, and, was never able to figure it out. I get 0 performance gains from a tiled landscape, tho, i am making a multiplayer online game, so i made it one giant landscape and called it a day. Haven’t had an issue since.

I know i didnt provide an answer directly, but, thats what i am able to give in this situation, my experience with the same issue.

Were you using weight blended or non weight blended layers?

Non tiles landscape isnt an option for me. Its not an issue with resolution, as the landscape imports perfectly when using weight blended layers.

Cheers!

The picture you posted shows layerinfo corruption tiles wise which can happen when the alpha maps aren’t in the correct order or if you hit the texture limits on the materials setup.

There have been texture limits on landscape materials since the first UE4 versions as these answerhub posts explain:

https://answers.unrealengine.com/questions/46706/painting-corrupt-quads.html

https://answers.unrealengine.com/questions/555844/creating-complex-landscape-materials.html

So is either that or your layerinfo got corrupted for other reasons.

Well its more than likely the layer info problem.

As I’ve said, the material works fine on a normal landscape tile. I can paint and un-paint all layers in one component.

There is no option to change the order of the layers when using a non-weight blended material.

OK. I figured out how to get it to work but its a bit of a hash.

Import the tiled landscape using a simple weight blended material with all the layers you want to use in the correct order and named properly.

When it’s imported. Replace the weight blended material with your non weight blended material. Save and close the editor. Then in explorer, copy a set of non-weight blended layer info files over the ones created by the tiled import.

Done. It works perfectly. It just took a bit of setting up and figuring out.

Cheers all.

Hey Thorax,

sorry for hijacking the thread.
How did you originally manage to import your weightmaps in the first place. I basically want to do the same thing like you, but my material won’t even work initially.
I have detailed my problem here: Setting up a tiled landscape material with Layerblending - Unreal Engine Forums
I guess perhaps my export settings/philosophy is wrong?

Kind regards

To answer OP.
its literally as easy as Open the LayerInfo file and unchecked the weight blend.

Also, had you hovered over the checkbox next to the layer name on the import, you’d have seen that it controls whether the layer is weight blended or not.

@highjacker, will check your thread.